WordPress.org

Ready to get started?Download WordPress

Forums

First time installing WordPress...having problems (4 posts)

  1. Guamgirl101
    Member
    Posted 10 years ago #

    Hello,
    This is my first time not only installing WordPress, but installing a blog in general. I've been to various sites that have blogs, one in particular mentioning that they got their blog from here, WordPress, so I decided to try it out and downloaded it from wordpress-1.0.1-miles.zip.
    Anyway, I've uploaded all the files to my server, and have gone as far as editting the wp-config-sample.php file to include my database username, password, etc, and then re-naming it wp-config.php. But when I try to launch /wp-admin/install.php in my browser, it came up with this error message:
    ---------------------
    We're having a little trouble selecting the proper database for WordPress.
    Are you sure it exists?
    Your database name is currently specified as wordpress. Is this correct?
    On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?
    ---------------------
    I'm lost at this point. It asks if it exists, but I thought the install.php file would install the wordpress database to make it exist. And I did give the name "wordpress" for the database name in the wp-config.php file. I've also double-checked the wp-config.php file after I tried accessing the install.php file and the changes I made there are still there the way I typed them in. Last but not least, I know my host supports PHP and MySQL databases because a friend of mine installed a guestbook on my site for me, and all my website pages are in .php format (they used to be in .htm format but I changed everything to php with some help from someone).
    I will mention that in the readme.htm file, when it says that "the weblogs.com cache file needs to be writable by the web server. CHMOD 666 the weblogs.com.changes.cache file," I was confused at this step and skipped it, since it said it was optional.
    I'm not sure what other bits of information I need to give here in order to help you guys help me, but let me know and I'll do what I can to provide any other info.

  2. Cena
    Member
    Posted 10 years ago #

    WP does not install a database for you. If you already have one you're using, the name of the WP database is going to be the same (in all likelihood), since most hosts only give you one. Probably, the db name you're using for your guestbook is the same you'll need to put in your wp-config.php.
    As far as chmodding goes, most FTP clients have an option (usually when you right click on a directory or file name) called something like 'chmod', 'permissions', or 'attributes' (varies according to the client.) It's here that you should set your permissions to 666.

  3. Guamgirl101
    Member
    Posted 10 years ago #

    Thank you, Cena, for the reply. Yes, I was starting to think that maybe I had to install the database myself to get the installation process started, so I just now added a new database separate from my guestbook and added my username. When I refreshed the install.php file in my browser, the error message went away and it's now working. For now, at least. lol. Thank you for letting me know, though, that WP doesn't install the database for me. That's what I had assumed.
    Also, thanks for the information on chmodding. Will it be okay if I did the chmodding after I finish installing WordPress? Now that I've got the installation program working, I want to see if I can get myself through it, and if I run into any more problems I'll try replying in this same post.

  4. Cena
    Member
    Posted 10 years ago #

    I'd go ahead and do it before installing, 'just in case'. :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.