WordPress.org

Ready to get started?Download WordPress

Forums

First Time Installation v1.5 (7 posts)

  1. hgbeeker
    Member
    Posted 9 years ago #

    I have tried everything so far but could not establish a database connection. Names are ok (copy-pasted). Could it be the prefixes
    my host is adding. example: 'Prefix_DB_NAME' / 'Prefix_User Name' etc.
    Maybe it is the '_' (underscore). Could anyone help me to go beyond this
    error messgage. Tks!

  2. hgbeeker
    Member
    Posted 9 years ago #


  3. Nick Momrik
    Member
    Posted 9 years ago #

    You'll have to contact your host for help with that. Any problems connecting to the DB should be related to using the wrong info in the connection or if your host is blocking it for some reason.

  4. alex2004
    Member
    Posted 9 years ago #

    Some more explanations would help :
    - are you upgrading from a previous installation ?
    - did it work before using something else ?
    - what is the exact error message that you get and when in the install proces do you get it ?

    Some of these might seem really evident, but this way we get more to go on...

    A thing to note is that when I did my installation, I could not make a database connection either - I had to change my mysql server name to the one my provider assigned me. Perhaps you can check this as well ?

  5. hgbeeker
    Member
    Posted 9 years ago #

    This is a fresh install - running the wp-admin/install.php.
    Message:
    ******************************************************
    Error establishing a database connection
    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at DB_HOST.
    Are you sure you have the correct username and password?
    Are you sure that you have typed the correct hostname?
    Are you sure that the database server is running?
    ******************************************************
    The hostname is 'localhost'. This should work for I tried the names with an other CMS before. I don´t know about the mySql name assigned to me or
    where to implement.
    Ah, the intallation is not in the root folder; could this be a problem?

  6. hgbeeker
    Member
    Posted 9 years ago #

    Ok, got it working. I pasted the names into the wrong section of the string: define('DB_NAME', '______ '); I replaced "'DB_NAME'. Sorry for trouble I gave you.

  7. angrybob
    Member
    Posted 9 years ago #

    Ah, the intallation is not in the root folder; could this be a problem?

    I am trying to install wp and am unsuccessful as of the moment. I did copy the files in a folder. Do the files or any specific files need to be in the root folder?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.