WordPress.org

Ready to get started?Download WordPress

Forums

First step installation probs (10 posts)

  1. a3bee
    Member
    Posted 6 years ago #

    help?
    I have a basic problem setting up Word Press. I managed to download all the needed files (i hope), saved my wp-config-sample.php as wp-config.php, then tried to open /wp-admin/install.php in my browser...

    Really dumb of me BUT - what is my browser and how do i do that? I've never seen a 'php' before... what application opens this?

  2. justinratwebtek
    Member
    Posted 6 years ago #

    Your browser is what you're using to view this post. In the address bar at the top (where is says: http://wordpress.org/support/topic/129684...), type in http://yourdomain.com/$$/wp-admin/install.php and just hit enter and follow the step.

    Now, going off your registered domain (http://www.lillymouse.com), I can't tell which directory you put wordpress into, so you need to add that where the $$ is.

  3. a3bee
    Member
    Posted 6 years ago #

    mmm ?
    how do i format my directory to include in the url above. I've used:

    http://yourdomain.com/C:\Program Files\Wordpress/wp-admin/install.php

    I also tried:
    http://yourdomain.com/C:/Program Files/Wordpress/wp-admin/install.php

    This hasn't worked... it simply goes to the YourDomain.com homepage?

  4. Doodlebee
    Member
    Posted 6 years ago #

    Um, did you upload the files to you webspace, or are you trying to run it on your computer? (and "http://www.yourdomain.com" is an *example* - meaning replace that with YOUR DOMAIN, whatever it is where your website is hosted.)

  5. markteh
    Member
    Posted 6 years ago #

    I am facing somewhat the same problem.

    After saving saved my wp-config-sample.php as wp-config.php, I uploaded the entire files to my web server simply by copy & paste.

    Next, everytime I tried to open /wp-admin/install.php, the dreamweaver program was activated.

    Then I followed the instructions and open the file through the browser as follows: http://yourdomain.com/$$/wp-admin/install.php.

    But the following error appears: "Your PHP installation appears to be missing the MySQL which is required for WordPress."

    How do I get around it?

    Thks

  6. justinratwebtek
    Member
    Posted 6 years ago #

    It sounds like your config.php isn't setup correctly - ie: it can't even find the MySQL server, let alone login and select the proper database.

    You may want to have your web hosting provider help you set this up.

  7. Root
    Member
    Posted 6 years ago #

    Just to recap from Step #1.
    WP requires to be installed on a web server. That means with a web host. Or locally if you insist to something like XAMPP. In either case prior to running the install routine you need to set up a mysql db and add a user to it with the necessary permissions. Then fill out config.php. Then using your browser (I guess that means Internet Explorer here) navigate to the install.php file url given above. Then do the necessary incantations etc and pray. :)

  8. justinratwebtek
    Member
    Posted 6 years ago #

    Actually, if the MySQL server name issue doesn't work, you're going to need to post exactly what you're doing on which server. ie: home machine running xamp or a domain name (whats the domain?) and who your host is and what package you have - this will allow all of us to understand your situation much better.

  9. markteh
    Member
    Posted 6 years ago #

    I have set up a MySQL account in my host. Following is the exact words in my wp-config.php file:

    <?php
    // ** MySQL settings ** //
    define('DB_NAME', 'mydbname'); // The name of the database
    define('DB_USER', 'mydbname'); // Your MySQL username
    define('DB_PASSWORD', 'mydbpw'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');
    require_once(ABSPATH.'wp-settings.php');
    ?>

    I am using GoDaddy as host.

    When opening up install.php the same error appears again, ie. "Your PHP installation appears to be missing the MySQL which is required for WordPress."

    Where did I go wrong?

  10. Root
    Member
    Posted 6 years ago #

    Quite commonly on web hosts (but mileage varies) you need to put your user name first eg: username_nameofmysqldb etc. Same goes for the db user. Read your hosts docs.

Topic Closed

This topic has been closed to new replies.

About this Topic