WordPress.org

Ready to get started?Download WordPress

Forums

First install - can't login (path problem) (5 posts)

  1. Flitwick
    Member
    Posted 8 years ago #

    I just installed WordPress for the first time. Installation ran smoothly and I see the default blog page. But when I try to log in I get the error

    Warning: main(/home/www/flitwick/html/blog//wp-admin/menu.php): failed to open stream: No such file or directory in /home/www/flitwick/html/blog/wp-admin/admin.php on line 40

    ...and so on. The error is obviously coming from the double slashes so I browsed this forum and googled around.
    I checked the 'site_url' and 'home' values for trailing slashes - nothing (I didn't even had a value in 'home' but it makes no difference if I set one. I have set 'site_url' to http://www.myblogwebspace.de/blog)

    I also tried to alter the define string in the wp-config.php but that gave even more errors so I changed it back.

    I'm stuck. What can I try next?

  2. Mark (podz)
    Support Maven
    Posted 8 years ago #

    Who is your host ?
    One function relies on a host setting, and if they have added a slash where there should not be one, you get the extra one appearing.

  3. Flitwick
    Member
    Posted 8 years ago #

    Which setting do you mean?

  4. Mark (podz)
    Support Maven
    Posted 8 years ago #

    It's a host php.ini setting which you cannot change.
    I asked for your host name so we could search that here to see if others had any issues.

  5. Flitwick
    Member
    Posted 8 years ago #

    It's a small local provider in Germany, doubtful that anybody else here shares webspace there. But the specific setting would be interesting because I can check with phpinfo(); and post the results here.

Topic Closed

This topic has been closed to new replies.

About this Topic