WordPress.org

Ready to get started?Download WordPress

Forums

WP External Links (nofollow new window seo)
[resolved] First external link in post/page not being processed! (12 posts)

  1. Sith Lord Goz
    Member
    Posted 1 year ago #

    Hi -

    It seems that the first <a> tag in any piece of content being processed by your plugin (page, post, custom widget etc.) is NOT getting processed/checked for being external.

    If I make a page or post where the FIRST link encountered is <a href="http://example.com/">Link</a> , it does NOT get processed as External. However, if I add a dummy <a></a> anywhere BEFORE that first external link, things work as they should.

    I tested this in a new, clean WP 3.5.1 install with HTML5Reset theme, and only one plugin: External Links 1.31

    Could you please examine? I've not noticed this bug before (I've used your great plugin for a while) but it could be that the content usually has other links first.

    Thanks for your work on this plugin!!

    http://wordpress.org/extend/plugins/wp-external-links/

  2. Sith Lord Goz
    Member
    Posted 1 year ago #

    To demonstrate this, I've made a really simple out-of-the-box site to show:

    http://wordpress.twiginteractive.com/test-post-with-no-dummy-tag/
    http://wordpress.twiginteractive.com/test-post-with-dummy-tag/

    As you can see, the first isn't processed, but the second one is. Only difference is the <a></a> tag.

    Interestingly, if you go to the homepage:
    http://wordpress.twiginteractive.com/

    BOTH links work, presumably because there is an <a> tag preceding them both (inside the <h2>)

  3. freelancephp
    Member
    Plugin Author

    Posted 1 year ago #

    Hello Sith, thanks for your demo pages. Could you please keep them live for a couple of weeks?
    So I can take a look at it when I have more time.

  4. elektrikpete
    Member
    Posted 1 year ago #

    I'm also seeing the same issue, inserting empty dummy tags solves the problem but it'd be great not to have to do that. Still though, apart from that the plugin is great, thanks for the hard work!
    Cheers
    Pete

  5. Sith Lord Goz
    Member
    Posted 11 months ago #

    Hi - any update on a bug fix for this please? Thanks!!

  6. hansopanso
    Member
    Posted 11 months ago #

    Same issue here!
    First link isn’t processed…..
    I will try the “< a > < /a >” solution though.
    Cheers

    [EDIT]
    Thought you might want to know....
    I placed a first link inside< h4 > < / h4 > here the external link is processed! Please see:
    http://voorleusden.nl/2013/04/kinderkledingbank-in-leusden/
    (just below the image)

  7. Sith Lord Goz
    Member
    Posted 10 months ago #

    I just saw that the author released v1.40 with this bug fixed. Excellent stuff - thanks so much!

  8. freelancephp
    Member
    Plugin Author

    Posted 10 months ago #

    Sith, thanks for testing.

  9. hansopanso
    Member
    Posted 10 months ago #

    Author....Cheers!!!!!!!!

  10. freelancephp
    Member
    Plugin Author

    Posted 10 months ago #

    hansopanso, thanks for your input.

  11. hansopanso
    Member
    Posted 10 months ago #

    Hi….
    Unfortunately the plugin now opens internal pages in a new tab.

    On the site VoorLeusden.nl i have a custom side menu. The first link opened in a new window so I had to disable the plugin to resolve the problem.

  12. hansopanso
    Member
    Posted 4 months ago #

    Resolved by adding my url in the "Ignore links (URL) containing... " box.
    Cheers!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic