WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Firefox Won't Display Themes (13 posts)

  1. mindtonic
    Member
    Posted 7 years ago #

    Hello,

    I just installed wordpress. Explorer shows the themes correctly, but Forefox looks like plain code with no RSS. The theme is not displaying at all. I use firefox exclusively, so this is not so good. Any ideas? Dod I miss something?

    Thanks!

  2. Chris_K
    Member
    Posted 7 years ago #

    Got a link we could check?

  3. whooami
    Member
    Posted 7 years ago #

    url? i would rather not hunt around your domain and my mind reading skills are not so good in the morning.

  4. mindtonic
    Member
    Posted 7 years ago #

  5. whooami
    Member
    Posted 7 years ago #

    mmm, very interesting, if i use the web dev extension to edit your css the theme displays as it should. close the sidebar, it does back to being naked.

  6. mindtonic
    Member
    Posted 7 years ago #

    Categories is the name of the theme I was using...

    I changed it to default to see if that makes it easier for you to find a problem.

    THANK YOU!!!

  7. mindtonic
    Member
    Posted 7 years ago #

    Now that is interesting. I just tried web dev too and had the same results. very strange...

  8. whooami
    Member
    Posted 7 years ago #

    since you just installed it, and since it happens with both themes, and since I dont have any other ideas. I would say thats its somehow related to your usage of the subdomain. I cant, unfortuntely, offer a futher explanation or fix. There are a few people that have worked out other issues with subdomains that hopefully will come along and read this.

    I would, if i were you, doublecheck that you have set up your siteurl and home settings correctly in the backend. I would also check to make sure that your wp-content/ and your wp-content/themes/ directories are BOTH chmod'd to 755. While I can bring up your style.css in my browser Im getting forbidden messages on the actual directories -- it might be due to their not being an index.php in the dirs, it might not. Just doublecheck the permissions to be sure.

  9. mindtonic
    Member
    Posted 7 years ago #

    Thank you for your time and assistance. I will try your suggestions and post the results here.

    If anyone else comes along and has similar problems or ideas, please let me know. Seems awfully strange the it works in explorer but not in firefox!

    THANKS AGAIN!

  10. mindtonic
    Member
    Posted 7 years ago #

    It looks like everything is set as you directed... no change in the display results...

  11. mindtonic
    Member
    Posted 7 years ago #

    Hey everyone...

    Here is how to fix this, complements of Alex from eGlobal design (http://eglobaldesign.com):

    I believe the problem you’re having is because of some header stuff. You should see an error about content type if you open up the javascript console in firefox when you load this page. I’ve run into this before, it usually just throws a warning message; I don’t know why it sometimes breaks the whole stylesheet. It’s because .css files on our webserver are processed by PHP before getting sent, which gives it a “text/html” content type instead of “text/css”. I’ve gotten around this before by adding some extra PHP code at the top and bottom of the stylesheets to set the correct header.

    Put this bit of php code at the top of your stylesheet:

    <?php
    ob_start();
    header("Content-Type: text/css");
    ?>

    And put this at the end

    <?php
    ob_end_flush();
    ?>

  12. bmoguy
    Member
    Posted 7 years ago #

    I'm having the same problem at http://www.oleseagull.com

    I don't understand where to put the bits of code. how will php know to process them if they are in the css file (which is what I assume you meant by stylesheet)? This is frustrating.

    thanks

  13. bmoguy
    Member
    Posted 7 years ago #

    I did some more digging and adding:

    AddType text/css .css

    to httpd.conf did the trick for me.

Topic Closed

This topic has been closed to new replies.

About this Topic