WordPress.org

Ready to get started?Download WordPress

Forums

Firefox redirect loop (24 posts)

  1. darrent71
    Member
    Posted 4 years ago #

    When I upgraded my WordPress to version 2.8 every time I try to login using Firefox 3.5 I get stuck in an infinite loop.

    From the login page I type in username and password, the browser changes the url to mydomain.com/wp-admin/ then back again to mydomain.com/wp-login.php?redirect_to=http%3A%2F%2Fwww.mydomain.com%2Fblog%2Fwp-admin%2F

    This doesn't happen with my PC in work, just my laptop at home. From my laptop I've no such problems logging in with IE7. I've cleared everything from cookies to cache and it still makes no difference.

    Can anyone help?

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Site url?

  3. darrent71
    Member
    Posted 4 years ago #

    it's gossy.us

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    No problems here connecting via Firefox 3 or IE8. Could it be a network issue on your work PC?

  5. darrent71
    Member
    Posted 4 years ago #

    Maybe I didn't explain correctly. I can reach the login screen but after typing in my credentials it reloads the login page with the url then showing as gossy.us/wp-admin/ then back again to gossy.us/wp-login.php?redirect_to=http%3A%2F%2Fwww.gossy.us%2Fblog%2Fwp-admin%2F

    This is a loop I cannot get out of.

  6. esmi
    Forum Moderator
    Posted 4 years ago #

    I did manage to replicate a similar error (though not a redirection loop) by trying to access http://gossy.us/wp-admin. What's in your .htaccess file. Are you redirecting www. to the bare domain name?

  7. darrent71
    Member
    Posted 4 years ago #

    I've just realised I gave you the wrong domain! Gossy.us is running on WordPress but I can login fine with it. It's acquiweb.com/blog that I keep getting the redirect on. Sorry! There is no .htaccess file for acquiweb.com and as I mentioned above, I can login fine from work or using IE7 on my home laptop.

  8. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried disabling all Firefox add-ons on your home machine?

  9. darrent71
    Member
    Posted 4 years ago #

    I just tried that but still same problem.

  10. fsflip
    Member
    Posted 4 years ago #

    I have the same problem on my localhost wordpress. I downloaded and installed wordpress-mu. I go to http://wp/wp-login.php (wp - it's my local host) and entered correct login and password and redirected to http://wp/wp-login.php?redirect_to=http%3A%2F%2Fwp%2Fwp-admin%2F
    And again reenter login and pass and again redirect on this url.

    Please help.
    There are any solution?

  11. Spiguy
    Member
    Posted 4 years ago #

    I know I am a little late on this but thought it was relevant. I had this issue and it drove me nuts...I didnt have to reinstall Firefox...here's what I did.

    Tools--> options --> Privacy Tab
    Click on delete individual cookie (or all if you prefer)...find your site and delete it.

    Then clear ALL your cache and viola...I am back into my site.

  12. s_ha_dum
    Member
    Posted 4 years ago #

    I was also thinking it might be a cookie issue.

  13. seomartin
    Member
    Posted 4 years ago #

    for me, this is happening, but on every browser I have. Cleared cookies too...

  14. Douglas Karr
    Member
    Posted 4 years ago #

    I'm running into this as well - interestingly enough, only with Firefox and not with Chrome.

  15. eduguytoo
    Member
    Posted 4 years ago #

    I have the same problem with safari, and FF, have cleared cache, in both same issue, so looks like a bug

    any work arounds, need to access my admin section,

  16. eduguytoo
    Member
    Posted 4 years ago #

    Update I just tested on IE 8.0 on Win XP and got the same thing, 404

    wp-login.php?redirect_to=http%3A%2F%2F

    So this does not look like a cookie thing at all, looks like something else, any thoughts, on this,,

  17. eduguytoo - This is a VERY old post and was about WP 2.8

    Did you just upgrade to WP 3.0? If so, can you try deleting the wp-admin and wp-includes folders and reuploading them from a fresh copy of 3.0?

  18. eduguytoo
    Member
    Posted 4 years ago #

    edit, just tried that and still have the same issue, really strange, because yesterday it worked today not,

  19. zain68
    Member
    Posted 4 years ago #

    I'm having the same problem, just started this morning. I contacted my web host and they told me to type in /wp-login.php instead of the usual /wp-admin at the end of my domain that usually gets me into my admin login page. Typing in /wp-login.php worked, I was able to login, but once in my Dashboard I can't go anywhere. I'm redirected to that Error 404 page again.

  20. eduguytoo
    Member
    Posted 4 years ago #

    Ok, yes, that worked, and yes, it is working now, but I did upload a fresh copy of wp-admin

    What is interesting is that once logged in, all is well, very odd, when you get the 404 error, what exactly is the url, or can you see that, copy paste, it you can replace the domain with xxx if you like

    This is very curious.

    One minor thing, I did add a couple of lines to force wp-config.php to define the site url, if you want to try that I will post it but save a copy of your config file before doing this, just let me know

  21. zain68
    Member
    Posted 4 years ago #

    I ended up logging out then logging back in and I was able to finally get around to do what needed doing this morning.

    Very freaky feeling, though, to suddenly be unable to get into my own site!

  22. zain68
    Member
    Posted 4 years ago #

    Just in case this happens again...what lines do you add to the wp-config.php?

  23. zain68
    Member
    Posted 4 years ago #

    ...and where would I put them? I'm a complete newbie at all this stuff. Most of what I manage to fix is through stumbling around and getting lucky.

  24. eduguytoo
    Member
    Posted 4 years ago #

    Now before you try this do one of two things, either rename your wp-config.php file to something like wp-config.phpx or save it or both,

    toward the bottom of the file you can do this,

    under this line should be around line 173

    define('ABSPATH', dirname(__FILE__) . '/');
    
    define('WP_HOME','http://www.yourwebsite.com');
    define('WP_SITEURL','http://www.yourwebsite.com');

    replace your website.com with your real website.com
    let me know if that works for you,

Topic Closed

This topic has been closed to new replies.

About this Topic