WordPress.org

Ready to get started?Download WordPress

Forums

Firefox problems (16 posts)

  1. Thecodont
    Member
    Posted 6 years ago #

    Hi,

    is there a known but in WP 2.3 that has a problem with Firefox? No matter what theme I use my posts look fine in IE7 but are either all pushed to the left with sentences that don't wrap within the container. Is this a CSS issue or something with one of the posts?

    http://www.joyceanddoug.com/blog

  2. sparklesperson
    Member
    Posted 6 years ago #

    I'm suddenly having the same or similar issue. I set up my blog last week, set up a theme, checked it in Firefox, and it looked fine.

    Posted a link to my list, and now only the header and footer show up, the linksrolls are pushed way down, and post backgrounds aren't showing... but only in firefox!

    I reinstalled, thinking it might be a WP bug, but no luck.

  3. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    It is not FF or WP. You have an error somewhere. If this started with "posted a link" then check there for a start.

  4. Suggymoto
    Member
    Posted 6 years ago #

    I'm having similar issues. Re-installed WP but no change. It is a WP issue. Looks ok until a picture is posted and then all hell breaks loose. Firefox can't even handle the default and classic themes. Just as well I use IE really! Irritating though.

  5. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    suggymoto - First correct your code so it validates at http://validator.w3.org/ Then in FF you can use the error console to show possible errors. Hopefully the problem can be solved with those actions.

    Thecodont - do the same. Your blog failed validation which means it will display with unexpected results.

    Also both of you should check to make sure any widgets you are using are compatible with WP. Often WP updates and Widget creators do not.

  6. michaelbradley
    Member
    Posted 6 years ago #

    I have the same problem. I updated all the code as requested in the WP update service and that didn't fix it. I figured it was the template I was using so I went back to the kubrick theme that was provided in the download, removed widgets, validated code in the w3.org validator, upgraded firefox and I have the same problem. It works fine in IE7 and Opera but not FF or Flock.

    Any suggestions?

  7. michaelbradley
    Member
    Posted 6 years ago #

    I read a bit more of KMessinger's reply and realized that I missed the console check in FF. This is the error that I've received.

    Error: The stylesheet http://domain.com/blog/wp-content/themes/default2/style.css was not loaded because its MIME type, "text/html", is not "text/css".

    Source File: http://domain.com/blog
    Line: 0

    No matter the theme, the result is the same. Thanks for the advice, I'll continue looking into it. If you have a suggestion, please let me know.

    Best regards.

  8. kmessinger
    Volunteer Moderator
    Posted 6 years ago #

    Thecodont - yours look fine in FF

    suggymoto - the Flash movie is causing your problem

    michaelbradley - it would be good to have a url so we could check things out

  9. michaelbradley
    Member
    Posted 6 years ago #

    I've changed it back to the proper theme. The URL is http://freewordsofchrist.org/wocm/

    Thanks!

  10. michaelbradley
    Member
    Posted 6 years ago #

    I'm almost convinced the condition can be cleared up with a modification of the .htaccess file or a chat with my host. Thoughts?

  11. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    I'm almost convinced the condition can be cleared up with a modification of the .htaccess file or a chat with my host. Thoughts?

    Sure, it's worth a try. Add this to your .htaccess (first line):
    AddType text/css .css

    That'll do it for a temporary fix. Alternatively, the host needs to modify their server configuration to set *.css to be text/css files. Them doing it is better in the long run than the .htaccess fix, but that should work if you have .htaccess enabled correctly.

  12. michaelbradley
    Member
    Posted 6 years ago #

    YES! That worked.

    In .htaccess, add:
    AddType text/css .css

  13. CaseyG
    Member
    Posted 6 years ago #

    Hey Michael - thanks for the solution.

    Can you step me through what I need to do? I don't know about the .htaccess file - and adding to it. Can you explain where it is, getting to it and changing it please?

    thanks

  14. moshu
    Member
    Posted 6 years ago #

  15. CaseyG
    Member
    Posted 6 years ago #

    Thanks Moshu!

    Okay - so i've found the .htaccess. I tried to edit it using FTP on the blog. It wouldn't allow access. So I downloaded it and tried editing it there. It wouldn't allow me in either.

    can you help me. the "You can edit the .htaccess file by FTP" is a bit advanced in assuming I know how to edit it.

  16. Suggymoto
    Member
    Posted 6 years ago #

    Yeah my problem was fixed. It is embedded Flash posts that cause the problem. I've now installed a plugin for adding video files and it works fine - Vipers Video Quicktags

Topic Closed

This topic has been closed to new replies.

About this Topic