WordPress.org

Ready to get started?Download WordPress

Forums

FireFox Performance with WordPress (5 posts)

  1. brianbonner
    Member
    Posted 8 years ago #

    I started using performance to blog, but here is another editor that does not work well with WP in Rich HTML, so I use the text editor. however I would like to know how to get WP to stop stripping HTML I put into performance when posting. For instance my readers like my links to open in a new window. WP strips the target="_blank" from my links. I would like to stop this behavior. It also strips the span code it uses for formatting. Is there anyway I can edit this feature?

    Thanks.

  2. pcolson
    Member
    Posted 8 years ago #

    In the options - write panel, try unchecking "WordPress should correct invalidly nested XHTML automatically". Target is not valid xhtml code.

    Paul

  3. brianbonner
    Member
    Posted 8 years ago #

    I checked and I already have it unchecked Paul. It doesn't happen in the main write window, only performance, and in comments? I know there is a file somewhere that tells wp what code to allow, because I changed it once in 1.5, but I didn't follow the rules about keeping a log.

  4. kickass
    Member
    Posted 8 years ago #

    Hmm, last I looked "target" is a valid xhtml 1.0 transitional attribute.

  5. brianbonner
    Member
    Posted 8 years ago #

    I went into the kses.php file and target is in there:
    'target' => array ()),
    So why is it stripping it in comments and adding rel="nofollow"

Topic Closed

This topic has been closed to new replies.

About this Topic