WordPress.org

Ready to get started?Download WordPress

Forums

Improved Simpler CSS
MIME type problem if not logged (5 posts)

  1. luismore
    Member
    Posted 1 year ago #

    After last plug-in update I realized that the custom css file it's not loaded correctly. The error console says that the css file it's received in text/plain instead of text/css.

    The CSS it's not loaded and doesn't override the original CSS file.
    This only happens if you are not logged in. If your logged to your wordpress site, there isn't any problem.

    Anyone experiencing this problem?

    thanks in advance.

    http://wordpress.org/extend/plugins/imporved-simpler-css/

  2. model13
    Member
    Posted 1 year ago #

    I've encountered same thing. In this case it's a multisite installation and the custom CSS isn't loading on any of the sites.

  3. luismore
    Member
    Posted 1 year ago #

    I'm using multisite as well.

    May be this will help:
    Explorer doesn't care about the error, and loads the CSS anyway.
    But Chrome, Safari and Firefox only load the CSS if your logged as user, if not logged in,
    the CSS file it's sent as plain/text and it's not loaded by those browsers.

  4. jorfermo
    Member
    Posted 1 year ago #

    Same problem here on multisite setup.

  5. enej
    Member
    Plugin Author

    Posted 1 year ago #

    I think the way to fix that would be though some .htaccess magic.

    I am not sure why your server doesn't send css files that are in the uploads folder as css.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic