WordPress.org

Ready to get started?Download WordPress

Forums

firefox container problem (8 posts)

  1. mliam
    Member
    Posted 5 years ago #

    http://www.sketchygrid.com
    my site works in ie but when i view in firefox the background does not continue with the posts. any ideas?

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    You've got some validation errors that may be causing problems - especially the missing start and end tags. You could also do with changing <div id="topcont"> to <div class="topcont">. There should only ever be 1 named id in a page, so if you intend to use something more than once, assign it a class - not an id.

    In terms of the page background, I can't see any difference between the display in FF3 and that in IE8.

  3. mliam
    Member
    Posted 5 years ago #

    i see the errors but have no idea how to fix them. I've been trying to switch things around but all i seem to get is more errors.

  4. viceng
    Member
    Posted 5 years ago #

    if your talking about the grid type background, you need to change the css for the body background image from no-repeat to repeat-y.

  5. mliam
    Member
    Posted 5 years ago #

    no I'm talking about how the tan background only covers half of the page in firefox. esmi validation errors website probably found the problem but i don't understand what it wants me to do

  6. esmi
    Forum Moderator
    Posted 5 years ago #

    viceng is right. You need to edit style.css (line 168)

    #mainpage {
    background-color:#FFFFCC;
    background-image:url(http://www.sketchygrid.com/images/bg_2.png);
    background-position:right top;
    background-repeat:repeat-y;
    border-right:1px solid #000000;
    min-height:1000px;
    padding:0 10px 10px;
    width:100%;
    }

    and change background-repeat:no-repeat; to background-repeat:repeat-y;

    I tried that originally and thought it wasn't working. However, I've just pulled down a copy of the background image and I can see why. It's an 800px high image - most of which is actually plain yellow. Not sure you'll be happy with the result when you do get it tiling down the page.

  7. mliam
    Member
    Posted 5 years ago #

    just changed it-and its still getting cut off. even with the repeat the background dies.

  8. mliam
    Member
    Posted 5 years ago #

    Line 181, Column 22: document type does not allow element "div" here; assuming missing "li" start-tag
    <div class="topcont2"><h3>Meta</h3><ul>

    Line 195, Column 6: end tag for "li" omitted, but OMITTAG NO was specified
    </ul>

    not sure what these mean, to see where i got these from please look at esmi's validation error link.

Topic Closed

This topic has been closed to new replies.

About this Topic