WordPress.org

Ready to get started?Download WordPress

Forums

HTML5 jQuery Audio Player
[resolved] Firefox compatibility (16 posts)

  1. netgrrl2
    Member
    Posted 1 year ago #

    Hi,
    My playlists work ok with IE and Chrome but when I click the play button in Firefox 17.0.1 , the mp3 doesn't respond.

    thanx,
    Jane

    http://wordpress.org/extend/plugins/html5-jquery-audio-player/

  2. netgrrl2
    Member
    Posted 1 year ago #

    Looking back through this forum I see that I should try and update the MIME types. However, I am not sure of the syntax for adding the following to web.config (my server doesn't support .htaccess)

    AddType audio/ogg ogg
    AddType audio/ogg oga
    AddType video/ogg ogv
    AddType video/mp4 m4v

  3. Maeve Lander
    Member
    Plugin Author

    Posted 1 year ago #

    Very common firefox issue - see FAQs about mime types.

    If you can't add/edit htaccess via FTP then I'd suggest you contact your web host or server administrator for further assistance. Explain the issue and I'm sure they'll be able to help you get these mime types sorted out.

  4. netgrrl2
    Member
    Posted 1 year ago #

    Hi,
    I'm on IIS 7 server so I added the parameters to web.config. This didn't help.

    I then asked my ISP to add the MIME types directly. They did this for me and it's still not working.

    The player shows up as normal. when you click the play button, nothing happens.

    Any other ideas?

    thanx,
    jane

  5. netgrrl2
    Member
    Posted 1 year ago #

    Do you think it could be the way I encoded the ogg audio file?

    Are there any recommended settings?

  6. Maeve Lander
    Member
    Plugin Author

    Posted 1 year ago #

    What program did you use to convert to ogg?

    And does the ogg file play in firefox without the player? ie. right click the ogg file on your PC then click open with Firefox...

    Also are you able to please post a link here so I can check it out?

  7. netgrrl2
    Member
    Posted 1 year ago #

    Here's the link - I'm using Adobe Audition to convert the files. I'll do the checking now.

    https://www.caamamusic.com.au/blekbala-mujik-1995/

  8. netgrrl2
    Member
    Posted 1 year ago #

    Yes it plays in Firefox when I open the local file there

  9. netgrrl2
    Member
    Posted 1 year ago #

    Hi,
    I have to put the site back behind a placekeeper. I can PM you the login details if you like.

    thanx,
    Jane

  10. netgrrl2
    Member
    Posted 1 year ago #

    Hi,
    I uploaded WordPress 3.5 to a new folder, left the theme as the WP default and the only plugin I added was the player. The song still doesn't play. I'll contact my ISP to double check they correctly installed the MIME types..

    Here is the link

    http://www.caamamusic.com.au/blik/?page_id=2

  11. netgrrl2
    Member
    Posted 1 year ago #

    Response from my isp
    The MIME type has been added and the HTTP header shows that the web server is
    serving the files with the right MIME type as shown below.

    HTTP Response Header Value

    Status: HTTP/1.1 200 OK
    Content-Type: audio/oga
    Last-Modified: Sat, 29 Dec 2012 00:29:15 GMT
    Accept-Ranges: bytes
    ETag: "807ffe875be5cd1:0"
    Server: Microsoft-IIS/7.5
    X-Powered-By: ASP.NET
    Date: Sun, 30 Dec 2012 01:28:16 GMT
    Connection: close
    Content-Length: 491050

  12. netgrrl2
    Member
    Posted 1 year ago #

    All working now. My ISP made a mistake when updating the MIME types.

    Thanx for a fantastic app :)

  13. Maeve Lander
    Member
    Plugin Author

    Posted 1 year ago #

    Great! Thanks for reporting back netgrrl2. Glad it was the old MIME type issue and not something weird and new!

    If you like the plugin please do give it a nice rating -->

    Thanks! :-)

  14. netgrrl2
    Member
    Posted 1 year ago #

    I spoke too soon, the problem has returned... If you want to have a look at the page, let me know and I'll remove the placekeeper page :(

  15. netgrrl2
    Member
    Posted 1 year ago #

    lol - frkn web central - it was the MIME types again. Don't know how they managed to undo the settings..

  16. Maeve Lander
    Member
    Plugin Author

    Posted 1 year ago #

    ok marking this resolved now

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags