WordPress.org

Ready to get started?Download WordPress

Forums

Firefox 3 Quick Find Apostrophe Bug in WordPress 2.5.1 (13 posts)

  1. edelen
    Member
    Posted 5 years ago #

    A problem with Firefox 3 and WordPress 2.5.1: When typing into the main body of a post in the visual (rich) editor, hitting the apostrophe will bring up the Firefox Quick Find box above the status bar. With this problem, it is not possible to type the apostrophe character into the post text box. This bug does not occur in other types of text boxes or in the non-rich editor.

    I have tried every fix listed in the Firefox Knowledge Base and online. Nothing works. In the past this has been a known issue in Firefox except that it occurred in all types of text boxes rather than just one kind. Not only that, but a handful of solutions existed. I tried them all and had no success at fixing the problem.

    In short, this renders useless the editing box for posts in WordPress.

    Any ideas for fixes?

  2. Edelen,

    Works for me, I've just tried it on FF3 and WP 2.5.1. As long as the visual editor is focused (cursor is in the text entry box), I can't get the quick find link only to pop up on the bottom.

    Only when I click outside of the text entry box does the ' cause the popup on the bottom. Try disabling your FF3 extensions, maybe something is interfering with FF3.

  3. edelen
    Member
    Posted 5 years ago #

    Jdembowski,

    My install is clean with no extensions. Even when focused it does not work.

    I'm beginning to wonder if the problem is with the Tiny MCE Advanced plugin I'm using in WordPress. I'll have to check that out.

  4. edelen
    Member
    Posted 5 years ago #

    Nope, Tiny MCE Advanced was not the problem.

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Works fine for me too.

  6. edelen
    Member
    Posted 5 years ago #

    Guys, I don't know what to say. It may indeed work for you. But as we all know, that's the way some bugs work. There's obviously a problem here. I'm not making things up.

    Anyone out there besides me having this problem? It can't be just isolated to me.

  7. Anonymous
    Unregistered
    Posted 5 years ago #

    Not working for me too! Finding a way to disable this stoopid feature

  8. edelen
    Member
    Posted 5 years ago #

    After struggling with this and blowing away my Firefox install umpteen times, I finally looked at the Firefox installer itself. Sure enough, when I deleted the installer I'd downloaded and downloaded a fresh copy to install from...no more problem!

    I wonder if some of the server sites serving Firefox had a bad copy of the installer. I have no other explanation.

  9. Endolith
    Member
    Posted 5 years ago #

    This is a Firefox problem, not a WordPress problem. I have it in any rich-text field (WordPress, Gmail, Google Docs) on my work computer (Windows XP), but not on my home computer (Ubuntu). You can't type an apostrophe ' or a slash / because it brings up the find tools.

    You solved it by uninstalling and re-installing Firefox? This did not work for me.

  10. slobizman
    Member
    Posted 5 years ago #

    I also have the same problem.

  11. slobizman
    Member
    Posted 5 years ago #

    Just loaded FF 3.0.2 and sadly it is still doing the same thing. I'd like to be able write with contractions again. :)

  12. slobizman
    Member
    Posted 5 years ago #

    I did some research and TONS of people have this Firefox problem. it's not related to WP, as it happens with other products as well.

    The frustrating thing is that Mozilla is well aware of it, and it has been happening for some time through many versions of FF. BUT, they do not have a fix for it and they say they do not know how to fix it! It's a real problem.

    But!!! I found a solution. It worked for me!
    http://ffextensionguru.wordpress.com/2008/09/02/disable-apostrophe-invoking-quickfind-bar/

  13. jayneeR
    Member
    Posted 5 years ago #

    slobizman you are a star!
    I have been trying to fix that problem for months and months and was giving up hope.
    I have been having to open notepad just to put a ' and having to copy and paste it into a message box.

    Thanks a lot. :)

Topic Closed

This topic has been closed to new replies.

About this Topic