WordPress.org

Ready to get started?Download WordPress

Forums

Firebug/Chrome CSS editor rejects clear=none (10 posts)

  1. ChKatzman
    Member
    Posted 1 year ago #

    I'm trying to do custom formatting of a slideshow plugin.
    I want:
    1)a shadowbox surrounding the slide.
    2)the slideshow on the left and text on its right. Besides the slideshow, there are ordinary images above it that I want to keep on a separate line.

    I read W3 school's CSS guide, and I tested coding changes with both Firebug and Chrome's developer tools.

    I managed to get the shadowbox to appear just as I wanted it in with the developer tools (although I haven't yet succeeded in following the plugin author's instructions for making a "child plugin").

    On the other hand, the text wrapping, which appears to require much simpler code than a shadowbox, does not take effect even in the developer tool mode.

    After studying W3-schools' CSS guide, it appears that

    clear: left

    should make a line break right before the slideshow, and that

    float: left;

    should make the slide float left with text wrapping around its right.

    However, the developer tools crossed out clear: left and clear: none, and float did not cause text wrapping. I looked at the HTML code that had been generated, and found that the text was in its own div, not within the div of the plugin.

    There must be something that is putting the slideshow and text in separate divs and forcing a line break after the slideshow despite "float". It could be that the same thing is causing "clear" to be disqualified. I have not yet figured this out despite pouring over W3's CSS guide and doing searches in WordPress and in Google.

    How can I get the text to wrap around the slideshow?

  2. alchymyth
    The Sweeper & Moderator
    Posted 1 year ago #

    without a live link to illustrate the issue, nobody will be able to comment on your problem.

  3. CKatzman
    Member
    Posted 1 year ago #

    You can take a look at birthdoulajerusalem.com/cyclone-slider-2, but I as I said, I don't have the changes to the plugin within my theme, I only tried them with the developer tools.

    This site will expire on Tuesday, I'm planning to make a new one under a different domain name. I'm doing testing now with this one.

  4. bcworkz
    Member
    Posted 1 year ago #

    You have the right idea with float and clear. It appears the slider inline element style max-width: 410px is what is preventing the clear: left and float: left directives from being applied. Changing it to width: 410px allowed the float and clear directives to work. However, unless you can alter the output of the plugin, this may be of little help.

  5. CKatzman
    Member
    Posted 1 year ago #

    The value for the inline element width/maxwidth you mentioned is set in the WordPress dashboard when the user adds a slideshow. I searched within the plugin code; every width / maxwidth is 100%.

  6. CKatzman
    Member
    Posted 1 year ago #

    I have a sort of "child plugin" within my theme, but I'm not sure if any of the changes took effect. In any case, changing max-width to width there had no apparent effect.

    Erasing the width setting in the dashboard erased the slide. Setting it to the full width of the content area did not help. This figure defines the area that the element takes up within the content area, and should have no effect on its ability to float horizontally within that area, nor to admit text alongside it without forcing a line break.

    The problem is definitely that somehow a line break is being generated, as can be seen from the text being in a separate div.

  7. CKatzman
    Member
    Posted 1 year ago #

    What do you mean by altering the output of the plugin?

  8. bcworkz
    Member
    Posted 1 year ago #

    Unfortunately, all I know is what I see in the html output of your page. There one of the slider elements has an inline style attribute setting max-width: 410px; This is the output I'm referring to. I'm not sure where it really comes from, I assumed the slider plugin. From your description of the dashboard, it sounds like the plugin script is calculating this, possibly in javascript based on client window size, so your's may not be 410 but something else. Regardless, the inline max-width attribute is what is preventing float and clear from working.

    Changing max-width to width solves the problem, but I doubt you can do that without hacking the plugin, which I cannot recommend. However, since some allowance was made for a 'child-plugin', perhaps there is a way. Knowing nothing of this plugin, I'm sorry I can't be of much more help.

  9. CKatzman
    Member
    Posted 1 year ago #

    I tried what you suggested offline on a saved full webpage using Firefox browser developer tools, since my old site no longer exists and I'm having difficulties registering with a new host.

    Changing max-width to width had no effect on Cyclone Slider 2.

    I looked at the CSS code of Meteor Slides, which has an option for either right or left alignment with text-wrapping, which works perfectly. It uses max-width.

    If what you suggested worked, it would be easy to implement, since the file to be modified would be the common css file, which is simpler to deal with than the various Cyclone templates. Unfortunately, this does not seem to be the solution.

    I would really appreciate a reply from Cyclone's author.

  10. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    I would really appreciate a reply from Cyclone's author.

    For help with a specific plugin - please use the plugin's forum:

    http://wordpress.org/support/plugin/cyclone-slider-2

Topic Closed

This topic has been closed to new replies.

About this Topic