WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Finally got Super Admin menu - Still have major problems (4 posts)

  1. lokrin2000
    Member
    Posted 4 years ago #

    I was doing one thing that wasn't standard during the install - I was not using 'admin' as the administrator name, instead I was using something like 'Name Initial". After around five attempts of downloading WP 3.0 from trac or nightly build and doing a totally fresh install (including database, wp-config and .htaccess) I decided to keep the default "admin' name and I now have super admin. Looks like there may be a bug in the program.

    However, I am still getting lots of errors:

    http://www.xxxxxxxx.org/wp-admin/ms-admin.php
    Fatal error: Call to undefined function get_user_count() in /home/xxxxxxxx/www/www/wp-admin/ms-admin.php on line 21

    http://www.xxxxxxxx.org/wp-admin/ms-sites.php
    Fatal error: Call to undefined function get_blog_count() in /home/xxxxxxxx/www/www/wp-admin/ms-sites.php on line 421

    http://www.xxxxxxxx.org/wp-admin/ms-users.php
    Fatal error: Call to undefined function get_blogs_of_user() in /home/xxxxxxxx/www/www/wp-admin/ms-users.php on line 226

    http://www.xxxxxxxx.org/wp-admin/ms-options.php
    Fatal error: Call to undefined function is_subdomain_install() in /home/xxxxxxxx/www/www/wp-admin/ms-options.php on line 106

    http://www.xxxxxxxx.org/wp-admin/index.php
    Fatal error: Call to undefined function get_dirsize() in /home/xxxxxxxx/www/www/wp-admin/includes/ms.php on line 445

    http://www.xxxxxxxx.org/wp-admin/my-sites.php
    Fatal error: Call to undefined function get_blogs_of_user() in /home/xxxxxxxx/www/www/wp-admin/my-sites.php on line 13

    Just to name a few.

    I'm installed in the main domain and using subfolders as my host says that wildcards are not enabled on their servers.

    By the way,current download is from nightly build.

    Also,the nightly build page really needs to be updated.

    The current release of WP is 2.8. If you peek in the version.php file, you will see this:
    $wp_version = '2.8';

    If you would like to try out the latest development builds for the upcoming 2.8.1 release, change that line to this:
    $wp_version = '2.8.1-dev';

    "dev" can be any string. The presence of a suffix on the version tells the automatic upgrade to put you on the upgrade path for 2.8.1 development releases. You will be able to automatically upgrade to each nightly, beta, and RC build for 2.8.1. Once the final 2.8.1 release comes out, automatic upgrade will upgrade you to that official release and put you back on the stable release path. To get back on the 2.8 development branch upgrade path after the release of 2.8.1, you would have to change your version to "2.8.2-dev".

    If you are feeling really experimental, you can get on the 2.9 development path by setting the version to "2.9-dev". Unlike the 2.8 development path which contains only fixes to high-impact bugs, the 2.9 path is where new feature development is happening. You probably want the 2.9 path only if you are a developer.

    I would also suggest putting
    # define ('WP_ALLOW_MULTISITE', true ) ;
    in the sample config file with a not to uncomment it for multi sites.
    This would also help reduce the number of people asking how to enable multisites.

  2. Samuel B
    moderator
    Posted 4 years ago #

    create a blank php file named
    wp-includesms-files.php
    and drop it in your /wp-content folder and try it

  3. Frits1980
    Member
    Posted 4 years ago #

    @lokrin2000: please take a look at my reaction on your issues in the other post: link

  4. lokrin2000
    Member
    Posted 4 years ago #

    I had
    require_once(ABSPATH . 'wp-settings.php');
    at the beginning of the multisite lines in wp-config.

    Everything is ok now. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.