WordPress.org

Ready to get started?Download WordPress

Forums

Fileupload Url field is missing from the settings list on the secondary site. (19 posts)

  1. tonybussey
    Member
    Posted 5 months ago #

    Hi

    I can't upload images to my secondary sites:
    I’ve checked with my host and permissions seem fine, they also gave me the correct information to use in ‘Sk Wproot Folder’ field: /var/www/web/ and ‘Upload Path’ field: wp-content/unloads

    There's a similar question posted but it’s not helped me:
    http://wordpress.org/support/topic/fileupload-url-doesnt-show-up-in-setting?replies=25

    For info:

    ▪ I use the plugin ‘Change Uploaded File Permissions’
    ▪ I’ve mirrored the above setting on the secondary sites except for the missing Fileupload Url field

    Could this be the problem or am I barking up the wrong tree...
    Any help would be very very much appreciated!

    Thank you

  2. If it's a brand new site, you don't need it.

    What was the initial error?

  3. tonybussey
    Member
    Posted 5 months ago #

    No specific error; my images just down show up.

    All I get is a ? On the site preview and in edit mode.

  4. WordPress isn't giving you a single error at all? Okay, are the images located in the uploads/sites/# folders?

  5. tonybussey
    Member
    Posted 5 months ago #

    No, there's no error message; and there isn't a sites folder on my server.

    I have web/wp-content/uploads
    In uploads there's folders by year; 2013,2014 etc

    I've just tried manually adding a 'sites' folder and altered the settings in WP too... didn't work. Maybe I haven't installed multisite correctly? Maybe/maybe not?

  6. Which site on your network are you on?

    WordPress ALWAYS gives an error. If the sites folder can't be made, WP will say it can't copy files. So HOW are you trying to upload images? Are they in the uploads folder at all? Are they in the media library?

    What's in your .htaccess file?

  7. tonybussey
    Member
    Posted 5 months ago #

    In a effort to find the images on the server I've discovered they are located in blogs.dir

    (to be exact)
    web/wp-content/blogs.dir/11/files/2014/03

    Thank you for the replies to date by the way.

  8. tonybussey
    Member
    Posted 5 months ago #

    • I'm working on the secondary site,, the primary site works perfectly
    • Adding the images via the 'add image' button in the gallery post
    • Yes they are in the media library but it doesn't show the actual image; just blank/with a question mark
    • All the images for my primary site are in the uploads folder (added in exactly the same way, both sites are using the same theme).

    I promise I'm not getting any error messages.

    I can take a look at the .htaccess file but what would I be looking for?

  9. Yes they are in the media library but it doesn't show the actual image; just blank/with a question mark

    Then THAT is your error :) I promise. I didn't say error 'message' I asked what the error was. I should have phrased this different, but if something specific is broken, you have to tell us exactly what :)

    "My images upload fine, but they don't show in the media library" is a perfect 'error' example :)

    What's in your .htaccess file?

    This means "Please paste your .htaccess file here for us to review, so we can see what's in it and hopefully help you, since we know you don't know how to find it yourself, or you'd already have done so."

    It's okay. We know you don't know :) You're asking for help after all, right?

    Also remember to use the CODE tags (see the boxes above the text entry field? Use them :) please.)

  10. tonybussey
    Member
    Posted 4 months ago #

    It's okay. We know you don't know :) You're asking for help after all, right?

    Sorry, I'm new to this but hope to learn quickly and hopefully used these CODE tags correctly. I appreciate the help. Here's my .htaccess code:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
  11. tonybussey
    Member
    Posted 4 months ago #

  12. That one is an out of date .htaccess, and one that implies you set up multisite pre WP 3.5

    Is that the case? And if so, did this ever work?

    There are quite a few possible .htaccess configurations, depending on when you activated multisite : https://codex.wordpress.org/htaccess

  13. tonybussey
    Member
    Posted 4 months ago #

    Is that the case? And if so, did this ever work?

    It was mid 2013 when I activated it, but you pose a good question; I'm not sure it ever worked properly. I had this same issue on with the primary site when I but fixed that with help from my hosting company.

    I’ve checked with my host and permissions seem fine, they also gave me the correct information to use in ‘Sk Wproot Folder’ field: /var/www/web/ and ‘Upload Path’ field: wp-content/unloads

    Then never got round to creating secondary sites until now.
    There is also two other .htaccess files on my server.

    AddHandler php54-script .php .php5

    AddHandler php55-script .php .php5

  14. Go into wp-content/uploads

    Is there a folder call 'sites' in there?

  15. tonybussey
    Member
    Posted 4 months ago #

    No sites folder - just folders by year; 2013,2014 etc

    In a effort to find the images on the server I've discovered they are located in blogs.dir

    (to be exact)
    web/wp-content/blogs.dir/11/files/2014/03

    Thank you for the replies to date by the way.

    Images for the primary site are in wp-content/uploads/2014

    I have web/wp-content/uploads
    In uploads there's folders by year; 2013,2014 etc

    I've just tried manually adding a 'sites' folder and altered the settings in WP too... didn't work. Maybe I haven't installed multisite correctly? Maybe/maybe not?

  16. In a effort to find the images on the server I've discovered they are located in blogs.dir

    Yeah, they shouldn't be. Mid 2013 was WP 3.6 through 3.7.

    *sigh* Honestly, you have a bad install. How much data do you already have on these sites? If it's not much, I would clean up Multisite, reinstall WP, port the main site over, and start on something clean.

  17. tonybussey
    Member
    Posted 4 months ago #

    I was afraid you'd say that, *sigh indeed*. Oh well it's not the end of the world.

    Thank you for your help!

  18. tonybussey
    Member
    Posted 4 months ago #

    I would clean up Multisite, reinstall WP, port the main site over, and start on something clean.

    Hi Mika,
    I'm really worried about doing this.
    Just to check what you're suggesting and let you know what this involves for me;
    1. Remove existing WP installation from my server
    2. Reinstalled WP (I use a 1 click install provided by my hosting company)
    3. Activate multisite (tricky business for me)
    4. Setup my main site theme again and then import content via a exported xml file

    Is this correct or is there a better way to clean up multisite and port over my main site?

    Sorry if this is a lot to ask. I will do all of the above if that's what's needed or I'm happy to start a new thread and get your advice there. Thank you!

  19. Starting over with Multisite means ... starting over. Delete the old stuff that didn't work, reinstall everything fresh. Don't overthink it :)

    Then export the old data from your extant site and import.

Reply

You must log in to post.

About this Topic