WordPress.org

Ready to get started?Download WordPress

Forums

SE HTML5 Album Audio Player
[resolved] Files are not loaded into album (19 posts)

  1. Amefa
    Member
    Posted 1 year ago #

    Hi!
    I install plugin, activate it, adding new album and..., when i tryin add media into album (mp3), nothing do not happens, the album is empty.
    Shortcode works on page, cover is visible, but no one mp3 inside album.
    What im doing wrong?
    Maybe, its because in my wp template alredy exist column "album" (not plugin,its part of template - can not be disabled)?
    But i see both columns - my works (when i add media), yours - not.
    I really want to use your player, but I can not. Help please.
    Thanks!

    p.s. Sorry for my bad english.

    http://wordpress.org/plugins/se-html5-album-audio-player/

  2. sedevelops
    Member
    Plugin Author

    Posted 1 year ago #

    I don't think this is because of a conflict with your existing post type called 'album'.

    The plugin post type is only labeled 'albums', but in the code it is called something more unique se_album_collection to avoid conflicts.

    I am not sure why your mp3s are not showing up. Are you sure that you are adding the mp3s to the album post directly? The audio must be added to the media library from WITHIN the album post for it to become 'attached' to the album post.

  3. mekstra
    Member
    Posted 1 year ago #

    I have same problem - I can connect a picture to an album, but I cannot put mp3 in my album. It is impossible to save them.
    cry-cry I have tried for hours now.

  4. mekstra
    Member
    Posted 1 year ago #

    do you have a tutorial - images or video how to make an album and put mp3 files in it?

  5. Amefa
    Member
    Posted 1 year ago #

    Are you sure that you are adding the mp3s to the album post directly? The audio must be added to the media library from WITHIN the album post for it to become 'attached' to the album post.


    picture what im doing in plugin

    Im trying add media from my "library" and from "upload" - no one works. Name of file "demo.mp3" - no spaces, symbols or something like this. WordPress version: 3.5.2

  6. sedevelops
    Member
    Plugin Author

    Posted 1 year ago #

    @Amefa:
    This is odd. Using the add media button, you should be able to upload new media from your computer to the album.

    After you upload an mp3, even though the file does not attach itself to the album post, do you at least see the mp3 as part of your global media library? IN other words does the mp3 file actually get uplaoded to your site?

    As far as a tutorial goes, there are instructions in the README.txt file.

    But some folk are having difficulties anyway. So I will create a screenshot video soon to help demonstrate.

    Again, sorry for your troubles. They might be related to a plugin conflict. I notice that you have a few plugins altering the look of the album post screen, and I wonder if something is getting in the way.

    All i can say is that the plugin works very well for me on 3.5.2 and 3.6.

  7. Amefa
    Member
    Posted 1 year ago #

    I realy understand how it works plugin uploading and media adding.
    ---> Add album ---> bla, bla, bla
    ---> Add media ---> go to library
    ---> If no files in library ---> go to "uplosd" file from my computer (adding to library - i see mp3 there) ---> in next step file most be added to album post, but nothing do not happens.
    I repeat this action in various varints - changing file names, uploding new files, adding from library exist files - no on action helps.
    This plugin is very good for me (i like demo), and i want finally using this.

    Im already testing plugin on WP 3.6 - same problem, files not be added into post.

  8. st9ler
    Member
    Posted 1 year ago #

    I have the same problem here.

    P.S.: I use WP in russian; also some files are cyrillic-named.

  9. sedevelops
    Member
    Plugin Author

    Posted 1 year ago #

    I think I understand your mistake now. After you upload... Just save the album and be done. You do not need to insert the mp3 into post. Just upload from the album post's media button.
    Then you can insert the player Into a regular post by using the tinyMCE drop down in the post editor. Video coming soon. If these directions + the readme don't mAke sense to you, then hold off until I upload the demo video. It should help explain.

  10. Netz
    Member
    Posted 1 year ago #

    Same problem here....

    I already have my files uploaded and are just picking them!
    But my screen only shows ALBUM title and the button "Insert Media"
    No "Body" or text fields ?? NADA
    Just the box below like on posts page about links to WordPress standard or external ???

  11. Netz
    Member
    Posted 1 year ago #

    And... When picking the media files ... I get back to the "Album" (from media library) ??

    Can't see the files I picked - save and NADA
    When inserting the Album in a post... BIG NODE picture and NO files at all .. NADA

    Not much music here!! LOL

  12. mekstra
    Member
    Posted 1 year ago #

    Hi
    It is confusing. Now I got something to work. Here is how:

    You cannot use any soundfiles uploaded to the media (developer: right?)

    I do not want double up of soundfiles, so I deleted all, and started again.

    1. When the actual album is open in editmode, upload files - from another place on your computer - NOT from the medialibrary. when finished the uploads:
    2. click insert
    3. update your site

    You can use the mediafiles as link in other posts, !! but if you delete a file from the album, then you delete the file permanently
    This works for me - Developer: Is this the way?

    It would be so nice, if it was possible to use the medialibrary - hope this is possible in the future. It is a great plugin, but it is not optimal, .... yet

  13. st9ler
    Member
    Posted 1 year ago #

    What do you mean "from another place on your computer"? You mean files should be uploaded via ftp?

  14. mekstra
    Member
    Posted 1 year ago #

    No, not ftp.
    You can select files from a folder anywhere on your computer, dropbox or other places, by using the uploadfunction in the albums site (edit.mode).

    remember to attach them to the album and save before you leave editing the album - otherwise you have to start over, because you cannot attache files which already is in the medialibrary before making the album.
    You can use the mediafiles other places on the site. But if you will have them in an album you must attache there first. AND important: if you delete a file from the album you delete it permanently - also from other places on your site, because it does not excist.

    My english is not so good, I hope you understand my explanation,
    This works for me - I hope the developer will give an answer: is this the way to do it?
    - an update of the plugin would be nice, so it is possible to use the medialibrary regulary instead of this complicated way.

  15. sedevelops
    Member
    Plugin Author

    Posted 1 year ago #

    mekstra! Yes! you've got it right!

    That's how it works.

    If you want to use files that have already been uploaded, then just insert those audi files as links into your post (not album), and then use the AutoPlayer.

    Glad you figured it out. Thanks for sharing with this thread!

  16. sedevelops
    Member
    Plugin Author

    Posted 1 year ago #

    Resolved.

  17. sedevelops
    Member
    Plugin Author

    Posted 1 year ago #

    Here's a youtube demo video: http://youtu.be/vZAfrzXfD00

  18. Amefa
    Member
    Posted 12 months ago #

    Thank You very much!!! It's working.

    This is the best WP player ever! 5 Stars!

    Best regards! :)

  19. martin stratton
    Member
    Posted 7 months ago #

    "If you want to use files that have already been uploaded, then just insert those audi files as links into your post (not album), and then use the AutoPlayer."

    OK, I follow... but when I use an uploaded media file and insert it into the Album (as it is being built), it still does not show up. I must be doing something in the wrong order. Help. (http://iowaknightlife.org)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic