WordPress.org

Ready to get started?Download WordPress

Forums

File type does not meet security guidelines (3 posts)

  1. tnobs
    Member
    Posted 5 years ago #

    Hey

    I have two different users on my blog (2.7.wp), one is an "administrator", the other one is in a "editor" role.

    With the administrator role I'm able to upload a *.flv file to the media library through the normal post editor, but if I try to upload the flv file with the "editor" user, I get this error message:

    File type does not meet security guidelines. Try another.

    How can I allow the "editor" to upload a flv file, without upgrading him to an administrator.
    In the wp_usermeta table, there is a field called "wp_user_level", where the admin has 10, and the editor has 7. I tried it also with 8 and 9 for the "editor" role, didn't work either.

    There are some other posts about it, put in the new version, you can't go to MIME-TYPE settings, and I don't want to change some core files, because through an upgrade those get probably overwritten, don't they?

    Thanks

  2. tnobs
    Member
    Posted 5 years ago #

    Sorry for the double post, but I had some network problems...

  3. toorman
    Member
    Posted 4 years ago #

    I am having the same problem. I am able to upload on outlook msg file as admin but not as a normal (editor) user.

    I have made the necessary changes to the wp-includes/functions.php file. and I know it has the potential to work since admin is able to upload msg files.

    What do I need to do for WordPress 2.7 to allow regular users to upload files.

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Topic