WordPress.org

Ready to get started?Download WordPress

Forums

File type does not meet security guidelines (4 posts)

  1. tnobs
    Member
    Posted 5 years ago #

    Hey

    I have two different users on my blog (2.7.wp), one is an "administrator", the other one is in a "editor" role.

    With the administrator role I'm able to upload a *.flv file to the media library through the normal post editor, but if I try to upload the flv file with the "editor" user, I get this error message:

    File type does not meet security guidelines. Try another.

    How can I allow the "editor" to upload a flv file, without upgrading him to an administrator.
    In the wp_usermeta table, there is a field called "wp_user_level", where the admin has 10, and the editor has 7. I tried it also with 8 and 9 for the "editor" role, didn't work either.

    There are some other posts about it, put in the new version, you can't go to MIME-TYPE settings, and I don't want to change some core files, because through an upgrade those get probably overwritten, don't they?

    Thanks

  2. WordPress has a whitelist of file types that it trust.

    If you want to extend this list you need to install a plugin such as my WordPress mime-config plugin this will allow you to add extra file types to the whitelist.

    Hope that helps.

  3. yesmaybe
    Member
    Posted 4 years ago #

    thanks for the help with the mime-config plugin. I solved my issue my installing the http://dd32.id.au/wordpress-plugins/add-from-server/ so I could upload .flv file through ftp.

  4. kaifanun
    Member
    Posted 4 years ago #

    add from server gives the same error and the file is flv. It is already white listed.

    Any other ideas? I'm using IIS and wordpress2.85

    thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic