WordPress.org

Ready to get started?Download WordPress

Forums

File path changing when adding image (6 posts)

  1. NNDT
    Member
    Posted 4 years ago #

    When adding an image in a post through the image uploader, the file path ends up getting changed. This results in a blank image file instead of the desired image.
    Any help with this problem would be greatly appreciated.

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Can you post a link to an example of this?

  3. NNDT
    Member
    Posted 4 years ago #

    As this is a backend problem you would get prompted for a password. So I'll try to clarify a little more:
    I go to the image uploader (add an image). In the "From Computer" tab, I press "Select Files". I then upload an image (from my <home>/pictures directory). I then "Insert into Post".
    It shows up as a blank image. And the "HTML" tab shows that the URL has been changed to: <img src="https://www.agcu.org/wp-content/uploads/2009/11/00698_snowmountains_1280x800.jpg" />.

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    <img src="https://www.agcu.org/wp-content/uploads/2009/11/00698_snowmountains_1280x800.jpg" />

    https:?

  5. NNDT
    Member
    Posted 4 years ago #

    The entire site is on https:
    That is irrelevant to the issue though. I have a site on http: that is having the same issue. I think it has something to do with the added /2009/11/
    Wordpress used to upload things directly to /uploads/

  6. NNDT
    Member
    Posted 4 years ago #

    RESOLVED!
    The wonderful people on the IRC #wordpress channel were able to help me with this.
    The problem: Settings -> Misc -> uploads file path incorrect.
    The solution: Correct it.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.