WordPress.org

Ready to get started?Download WordPress

Forums

Loco Translate
[resolved] file MO disappeared/corrupted (7 posts)

  1. Azelbiz
    Member
    Posted 8 months ago #

    I used it to finish to translate my "wpsc-fr_FR.po" (wordpress e commerce)
    Everything goes well
    OK: File saved, wpsc-fr_FR.po
    But after refreshed my webpage, i din't see any change.
    So i decided to check again the file on Dashboard> manage translation.
    , but i couldn't find it !
    Disappeared !!!

    I made a test with finnish language.
    I just change few words.
    OK: File saved, wpsc-fi.po
    After that, i check again on Dashboard> manage translation, and Finnish have disappeared.

    On my Ftp, files are still there, but i couldn't open it with PoEdit.
    say "corrupted".

    PS : I cleaned my cache, but the problem is still there.

    I hope you could fix this problem.
    I'm not satisfied, I have to download again WPEC to recover my "wpsc-fr_FR.po" not corrupted.

    http://wordpress.org/plugins/loco-translate/

  2. timwhitlock
    Member
    Plugin Author

    Posted 8 months ago #

    I'm sorry you're not satisfied.
    It's hard to debug this without more information.

    I downloaded WPEC and have no problem saving the PO file without corruption.

    Could you perhaps email the corrupt file to support at localise dot biz ? It may contain some kind of clue.

    Can you also tell me what browser you are using, what version of the plugin you are running and whether there are any errors in your log files?

  3. Azelbiz
    Member
    Posted 8 months ago #

    wordpress 3.7
    wpec 3.8.12.1
    FF 24 for ubuntu

    saving the PO was not the problem.

    I have 2 problems :
    i couldn't see PO languages after an update. It seems it has disappeared (i tried with 2 differents languages). I thought it was a problem of cache, but not.
    then
    after downloaded wpsc-fr_FR.po from my FTP I couldn't open with Poedit.
    version 1.4.6

    I will send you the file.

  4. timwhitlock
    Member
    Plugin Author

    Posted 8 months ago #

    Copying our email conversation here, so it can help others:

    The 'corrupt' PO file you sent me has slashes added to all double quotes which suggests you either have PHP magic quotes enabled on your server, or WordPress added them by force. I've already got code in place to try and avoid the latter, but perhaps not all situations are accounted for.

    Please try disabling magic quotes on your server and let me know if this fixes your problem.

  5. Azelbiz
    Member
    Posted 8 months ago #

    Hello
    Thanks for you help.
    It fixed my problem.
    I saw that magicquotes were enabled on my server. It's now = 0
    I'm very satisfied by your prompt support and your plugin.
    Thanks Tim.

  6. eloylobogris
    Member
    Posted 6 months ago #

    Good night from Panama. Happy New Year. Sorry but just finished the translation into Castilian Topic Academica and not load. Someone might desirme to do? Thank you. Blessings.
    Google translator

  7. timwhitlock
    Member
    Plugin Author

    Posted 6 months ago #

    Could you please open a thread with your specific problem. This support issue has been resolved. Thanks

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.