WordPress.org

Ready to get started?Download WordPress

Forums

few questions (css and b2) (15 posts)

  1. Anonymous
    Unregistered
    Posted 10 years ago #

    hi!
    i've got two questions. first of all i have to say that i'm not a hero in css, php an so on.
    my first problem is, that i cannot remove thos "points" before "links" and "categories" on the right bar on my site. i also would like to remove the text "links" completly, but i dont know how. you can find my (temporary weblog) here: http://timbuk2.ch/weblog/
    my second question ist:
    whats the easyest way to upgrade my b2-weblog.
    i have my old weblog here: http://www.timbuk2.ch and i would like to kick the new one (url above) over the b2-based one. but i still want to have my old posts!
    so what's the easyiest way? at the moment there are two sql-databases.
    thank you fot all your reply's

  2. Mark (podz)
    Support Maven
    Posted 10 years ago #

    1 - http://wiki.wordpress.org/index.php/Bullets
    2 - Sorry, I don't know .. looks like you need to back up a database and merge it with the newer one .....

  3. Anonymous
    Unregistered
    Posted 10 years ago #

    sorry about the b2-question, just saw it in the readme-file. i searched wordpress.org and found noting.
    well, the problem with the bullets/dots is still not fixed. i just can't find the point to make them invisible.
    i would like to have the "links" and "archives" to look like the "register" and "login" above.
    here's again the site: http://timbuk2.ch/weblog
    it would be very very helpfull if someone could have a quick look at my css, im almoust sure its a damn little thing to change, but i just can't find it.
    http://timbuk2.ch/weblog/wp-layout.css
    thank you

  4. NuclearMoose
    Member
    Posted 10 years ago #

    sushubh - helpful as always.
    The bullets can be removed by using "list-style-type:none;" or shorthand "list-style:none" in the wp-layout CSS when defining the selectors in #menu. Also, podz gave a great link to help explain this.

  5. Anonymous
    Unregistered
    Posted 10 years ago #

    well, i already tried this one, but nothing changed.
    it would be very helpful if someone of you could have a quick view on my css ( http://timbuk2.ch/weblog/wp-layout.css )
    im sure he could tell me the fault...
    thank you

  6. Mark (podz)
    Support Maven
    Posted 10 years ago #

    Bingo :)))))
    In the CSS, you have this type of thing:
    #menu ul ul {
    list-style-type: none;
    font-variant: normal;
    font-weight: normal;
    line-height: 100%;
    margin: 0;
    padding: 0;
    text-align: left;
    }
    which works great, if the ul and ul are in a menu div.
    Your's aren't :)
    Put this into your CSS:
    ul ul {
    list-style-type: none;
    }
    and those dots will go away (they do in the Firefox editor)
    If you are not using the #menu div anywhere, then go through your CSS and remove the work '#menu' from any declarations which affect any ul or li, and you'll be fine :)

  7. Anonymous
    Unregistered
    Posted 10 years ago #

    well, after a change on the design i still have this damn problem.
    i just can't remove those damn bullets on the right.
    in fact i would like to replace them by an image. but first i tried to remove them completly.
    i removed every li and ul in the css and in the index.php, but they're still there.
    im going crazy because of this.
    it would be very helpful if someone could have a quick view on the php and the css, theyre located here: http://timbuk2.twirl.ch/weblog/wordpress-forums/
    the weblog is located here: http://timbuk2.ch/weblog
    thank you very much!

  8. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    This may be a good oppurtunity for you to learn some basic CSS:
    http://www.w3schools.com/css/default.asp

  9. tcervo
    Member
    Posted 10 years ago #

    i removed every li and ul in the css and in the index.php, but they're still there.

    Bingo. To turn off the bullets, you must do so in the CSS. So, by removing every li and us in the CSS...you've essentially shot yourself in the foot.

  10. Root
    Member
    Posted 10 years ago #

    And deleting them in the index will not effect a permanent change. The next time php does a call there they are. As specified by W3C, and in accordance with best design practice. The links are in lists. They by default come with a bullet. That is in the html specification. If you do not like them, they may be turned off in the CSS.

  11. Anonymous
    Unregistered
    Posted 10 years ago #

    Joining the party, I have a different css problem with my blog. I have soem mysterious gaps between the post-titles, meta-information etc. You'll notice them very easy because of the gaps in the borders. I know that my index-file lacks transitional xhtml (still), but I don't believe that it has soemthing to do with this.
    I tried with edit styles in firefox to fix it, but can't find the error, because I didn't put any margins in the div's...
    I'd be extremely happy if soembody could give me a hand! thanx

  12. Root
    Member
    Posted 10 years ago #

    OK. In .storytitle in wp-layout.css you have a lot of padding. Adjust accordingly. That is going to be a beautiful looking blog. If you haven't seen it guys do pop in. Fabulous IMHO.

  13. Anonymous
    Unregistered
    Posted 10 years ago #

    thanx for the flowers :-) Unfortunately, your tip didn't help first.....
    But hey, then I thought, lets put a margin:0px; into the same class and voilá! :-) thanx Root!!!
    Funny is, this trick didn't work before, but now it did... could this have something to do, that I fixed the XHTML validation?
    Please don't mind the side-bar.. I'm currently playing around with it!
    I can only say: this support is fantastic!
    ... and I like the design of my fellow swiss bloggers over at timpuk2!

  14. Anonymous
    Unregistered
    Posted 10 years ago #

    thanks man! ;)
    to my problem: i solved it! ..well' lets say it right: a friend solve it for me... :D

  15. Root
    Member
    Posted 10 years ago #

    Well at least we got you pointing in the right direction. Just remember those h tags add a lot of margin and padding by default. You need to turn it off like you did. Sorry I wasn't spot on first time out.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.