WordPress.org

Ready to get started?Download WordPress

Forums

(Fetch as Google) 301 Redirect Removed Permanently-After wordpress Own Directory (2 posts)

  1. ginteno
    Member
    Posted 4 months ago #

    Hi everybody,

    I just recently move my wordpress core files to a sub-directory(Own Directory) and make it my index directory everytime my root domain is visited. i recently followed a tutorial in a wordpress article here is the link of the tutorial. http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory
    I just followed the instructions there to move my core files to a sub-directory and make it my root domain, but after doing the tutorial google bot is having trouble crawling my website and has a 301 redirect error. i think it has something to do with the .htaccess, when i use fetch as google tool in webmasters it says something like this:
    --------------------------------------------------------------
    Fetch as Google
    This is how Googlebot fetched the page.
    URL: http://www.wusign.com/
    Date: Friday, December 20, 2013 at 4:10:22 AM PST
    Googlebot Type: Web
    Download Time (in milliseconds): 361

    HTTP/1.1 301 Moved Permanently
    Date: Fri, 20 Dec 2013 12:10:23 GMT
    Server: Apache
    X-Pingback: http://wusign.com/wusign/xmlrpc.php
    Location: http://wusign.com/
    Vary: Accept-Encoding
    Content-Encoding: gzip
    Content-Length: 20
    Keep-Alive: timeout=10, max=30
    Connection: Keep-Alive
    Content-Type: text/html; charset=UTF-8
    ----------------------------------------------------------------

    Here is my root .htaccess settings
    --------------------------
    RewriteEngine on

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
    ------------------------------

    Everything works well until google cannot craw my site because of the 301 redirect error..
    need some help guys. i will appreciate your replies.

  2. ginteno
    Member
    Posted 3 months ago #

    I already figured out the problem..
    I just change the setting inside general setting..
    i changed site url from http://wusign.com to http://www.wusign.com/

Reply

You must log in to post.

About this Topic