WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] FeedWordPress Not Working with 2.1 Patch (9 posts)

  1. PetLvr
    Member
    Posted 7 years ago #

    According to the Codex page or working plugins, the FeedWordPress plugin is supposed to work with the patch as mentinoed in http://wordpress.org/support/topic/54125?replies=8#post-499823 by member Trent.

    But, it is not working for me and I get this error message (under the Options/Syndication)

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ORDER BY cat_id' at line 1]
    SELECT cat_id, cat_name, auto_toggle FROM ORDER BY cat_id

    I have followed Trent's patch .. and the author leaves me in moderation today.

    Can anybody help? This is one of those "must-haves" for me.

  2. jessor
    Member
    Posted 7 years ago #

    The source says:

    $results = $wpdb->get_results(”SELECT cat_id, cat_name, auto_toggle FROM $wpdb->linkcategories ORDER BY cat_id”);

    afaik linkcategories isn't supported anymore (since wp 2.1), so $wpdb->linkcategories is empty which results in the mysql syntax error. change the source to categories and remove ', auto_toggle' also.

    I postet the complete fix (guide + download) on: http://blog.teranetworks.de/179/feedwordpress-issues-with-wordpress-21-fix/

    It may not be the best way but it's working for me and perhaps it does the job for you, too, until the author comes up with a new version :)

    regards,
    jesse

  3. davezac
    Member
    Posted 7 years ago #

    hi jessekeys
    maybe you are working on this now - i was unable to access your page getting an error for the wrodpress fix
    thanks for the work in progress though

    regards
    dave

  4. jessor
    Member
    Posted 7 years ago #

    hi dave,

    you're right, i was working at some plugins a few hours ago and there was an error for a few minutes. everything is fixed now :)

    hope the feedwordpress fix works for you, just write a comment if you encounter further problems.

  5. davezac
    Member
    Posted 7 years ago #

    hi jessekeys
    i'm still struggling with you fix, i'm using blixkrieg 2.1 (blix theme fixed for wp2.1)
    first off i tried to edit feedwordpress.php as in your notes on blog.teranetworks.de. uploaded and activated but still getting error on syndication page.
    re-entered a couple of rss links in and added to syndication - seemed to add ok but would not display list.
    so i copied the text file off your site and recreated the feedwordpress.php file, uploading and repeat testing.
    still not working.
    I also get errors on the update page, and no list of links in the combi box.

    i would appreciate any help you can offer - i would even load the same theme you have if i can only get it working again.

    regards
    dave
    http://kollect.co.uk/blog

  6. davezac
    Member
    Posted 7 years ago #

    hold on - jessekeys

    i think i have fixed it -(rather you have !)
    i missed the additional rss-functions.php and overwrote the 0.5 version
    i reverted back to my previous version of blix called hmmmm. will report back if the bixkrieg works

    thanks for the help
    regards

  7. jessor
    Member
    Posted 7 years ago #

    I'm sorry if I haven't pointed the rss-functions issue correctly.
    Please use feedwordpress 0.98 as a starting point, not any older version.

    By the way, the theme has nothing to do with feedwordpress at all. Only problem could be that the theme uses functions which aren't support in wordpress 2.1 anymore.

  8. mundi89
    Member
    Posted 7 years ago #

    I am having LOADS of trouble with feedwordpress.... I just posted a comment on the terranetworks blog as well.

    ____
    I have tried this isntallation on several blogs, and I seem to get different error's each time. On one, i got everything working correctly except post's from syndicated links never showed up. After that I started over, and the best I could do was get a screen that said "Cheatin, uh?" everytime I did anything related to feedwordpress. I just tried AGAIN tonight on another blog, and I am getting a new error (i have however seen this one before on one of my previous 8 installation attempts.)
    I get this error:

    Warning: Cannot modify header information - headers already sent by (output started at C:\Inetpub\vhosts\domain.com\httpdocs\wp-admin\admin-header.php:16) in C:\Inetpub\vhosts\domain.com\httpdocs\wp-includes\functions.php on line 1219

    WordPress then says "Are you sure you want to do this? Y/N" and when I select yes, my changes/new feeds don't stick.

    HELP!

  9. everyman
    Member
    Posted 7 years ago #

    Hi

    jessekeys' fix has given hope but still all I get with some blogs is a headline linked back to itself (i.e. no storey included) and for some I am unable to connect at all.

    http://downtowneastsideenquirer.ca

    Any and all guidance appreciated

Topic Closed

This topic has been closed to new replies.

About this Topic