WordPress.org

Ready to get started?Download WordPress

Forums

FeedWordPress - Display & formatting problems with RSS feeds (5 posts)

  1. juguar
    Member
    Posted 3 years ago #

    Hi,

    I have a WordPress site running 3.1.4. It is a test site and can be found at http://96.125.174.43/~powwows/ . I'm also running Buddypress, just installed the latest through the WordPress dashboard today.

    I'd like each RSS feed entry to have the following :-
    - title
    - categories/tags
    - date/time posted
    - a scaled image from the RSS feed itself
    - max 3-4 line excerpt from the article (if any) with a link to read more.
    - Clicking anywhere on the RSS feed entry should lead to a separate page with an expanded view of the post on the site itself. This page would have user's comments, related posts etc.

    I have the following problems:-

    (1) Can't get the original formatting of content to be retained on my site. E.g. if one of my feeds is from CNN, the article looks well-formatted with text-wrapping around images, YouTube videos embedded properly. None of that is getting carried over into my site.

    (2) It seems like FeedWordPress has two modes for Permalinks.
    Mode a- Permalinks point to: "The copy on the original website"
    That's not what I want. In this case, clicking on "Comments" also leads you to the original CNN article. This even though I have "Allow comments on syndicated posts" turned on in Syndication -> Posts & Links. I also have "Point to comment feeds from the original website (when provided by the syndicated feed)" set to point to my site.
    This is how I have it set up now because I want users to at least be able to read the whole article properly formatted at the source.

    Mode b- Permalinks point to: "The local copy on this website"
    The title actually leads to a page on my site (which is what I want) but no link to the original site is retained anywhere in the page. This is a problem. I want users to be able to visit the original site.

    (3) Images/Videos from the original article are not showing up on my site consistently.

    I've used WP-o-matic as well. Same problem. Which leads me to think the problem may be outside FeedWordPress or WP-o-matic. Under "Settings -> Reading", I have "For each article in a feed, show" set to "Full text". Changing that doesn't make a difference either.

    I've already searched this forum extensively and have not found a solution. Here's one. And this one, this one, this one & even this one.

    They all suggests editing a variety of php files -- single.php, index.php, home.php in the default theme. Mine is the buddypress default theme.

    Nothing has worked so far. Some of the entries are from 4 years ago. So I'm positive that a solution has been worked out by now.

    Would appreciate it you could point me in the right direction. Thanks.

    ~jug
    PS: My site is at http://96.125.174.43/~powwows/

  2. Zerotronic
    Member
    Posted 2 years ago #

    Hi mate,

    Did you find a solution to your second problem (the one where the permalinks point to "The local copy on this website")???

    I am trying to find a way to make FeedWordPress add the link to the source automatically at the end of the post but no luck yet.

    A little help would be greatly appreciated

    Thanks

  3. Zerotronic
    Member
    Posted 2 years ago #

    I wrote a solution to my problem so i am posting it here in case someone else has the same problem with me.

    First of all after you install, activate and configure FeedWordPress you must then install, activate and configure Add Attribution for FeedWordPress.

    After you install and activate both of the above plugins you have to edit two php files, 1)feedwordpress.php (which is inside your "FeedWordPress" plugin folder) and 2)add-attribution-feedwordpress.php (which is inside your "Add Attribution for FeedWordPress" plugin folder.

    Open feedwordpress.php

    find the following segment of code

    function the_syndication_permalink ($id = NULL) {
    	echo get_syndication_permalink($id);
    }

    and right bellow the "}" add the following segment of code

    function the_syndication_permalink_return ($id = NULL) {
    	$srclnk = get_syndication_permalink($id);
    	return $srclnk;
    }

    Then save changes to this file and close it.

    Then open add-attribution-feedwordpress.php

    Find the following segment of code

    <dt><code>[source-url]</code></dt>
    <dd>URL of the source you syndicated the post from</dd>

    and right bellow it add the following segment of code

    <dt><code>[syndication-source-link]</code></dt>
    <dd>URL of the exact location to the source you syndicated the post from</dd>

    Then find

    add_shortcode('feed-setting', array($ref, 'source_setting'));

    and right bellow it add

    add_shortcode('syndication-source-link', array($ref, 'syndication_source_link'));

    Then find

    remove_shortcode('feed-setting');

    and right bellow it add

    remove_shortcode('syndication-source-link');

    Then find

    function source_url ($atts) {
    	$param = shortcode_atts(array(
    	'original' => NULL,
    	), $atts);
    	return get_syndication_source_link($param['original'], $this->id);
    }

    and right above "function source_url ($atts) {" add

    function syndication_source_link ($atts) {
    	return the_syndication_permalink_return();
    }

    Save changes and close the file.

    Then go to your wordpress page and login to the dashboard.
    Go to Syndication -> Posts & Links and go all the way down to the Attribution Boilerplate.
    Click "Add new boilerplate" give the settings you like and then write the following code snipet in the white box:

    Source: <a href="[syndication-source-link]">[source-name]</a>

    Save changes and you are ready to go.

  4. jcoolbaugh
    Member
    Posted 2 years ago #

    Brilliant, Mate! Thanks for posting your solution - I was pulling my hair out trying to figure this out.

  5. amedd
    Member
    Posted 2 years ago #

    Can I add this to "defaults for all feeds" or does this have to be done for each feed. I have not started on this yet, I hope to this weekend. If it works , thank you so much and I will keep you posted.

Topic Closed

This topic has been closed to new replies.

About this Topic