WordPress.org

Ready to get started?Download WordPress

Forums

Feed Validator says feed not valid!! (19 posts)

  1. Momo Chama
    Member
    Posted 9 years ago #

    I am trying to syndicate my feed. First I tried to validate it and it returned this error. I am wondering what is happening and why? Also how can I fix it so that I am able to syndicate.

    Sorry

    This feed does not validate.

    *

    Feeds should not be served with the "text/html" media type [help]

    *

    line 4, column 0: Undefined root element: br [help]

    *

    line 5, column 0: XML parsing error: <unknown>:5:0: junk after document element [help]

    <b>Warning</b>: Cannot modify header information - headers already sent by ...

    Source: http://www.msmlwright.org/me/wp-rss2.php

  2. Cypher
    Member
    Posted 9 years ago #

    Your blog is borked. It isn't generating anything resembling a valid feed. What version of WP are you using?

    Regards

  3. Momo Chama
    Member
    Posted 9 years ago #

    I am using version 1.5

  4. Momo Chama
    Member
    Posted 9 years ago #

    what does borked mean if you don't mind me asking

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Very broken :)

    Have you tried to edit the wp-rss2.php file at all ?

  6. Momo Chama
    Member
    Posted 9 years ago #

    have not toucned the file and I wanted to ask question before I just went on making them worse! I didn't do anything this time though.

  7. Try disabling all active plugins and check the feed again.

  8. Momo Chama
    Member
    Posted 9 years ago #

    There are only three plugins and those are hellodolly, markdown and textile1 and they are all decativated already.

  9. Mark (podz)
    Support Maven
    Posted 9 years ago #

    I would delete the wp-rss2.php file and reupload a new one ?

  10. Momo Chama
    Member
    Posted 9 years ago #

    ok im going to try that

  11. Momo Chama
    Member
    Posted 9 years ago #

    not helping, the reuploading of the file. I still get the same not valid message. Also when I click on the link for the rss feed from my blog it says Feed is not a registered protocol. But I suppose those are two separate issues?

  12. CounterDax
    Member
    Posted 9 years ago #

    Same problem here, in Safari (on Mac), FireFox (on Win & Mac), IE (Win) and Netscape (Win)... the feed is considered invallid. Never touched the rss files whatsoever.

  13. brainwidth
    Member
    Posted 9 years ago #

    Take a look here.

  14. Momo Chama
    Member
    Posted 9 years ago #

    why am I getting this though, I read the information in the link above but I am having the same problem still!

  15. Check for excess white space on line 261 of wp-blog-header.php.

  16. Momo Chama
    Member
    Posted 9 years ago #

    I did and it still doesn't work also I uploaded another wp-blog-header.php from another of my installs (that works) but I keep getting that same message about line 261.

  17. Momo Chama
    Member
    Posted 9 years ago #

    well I guess i'll just give up, I tried everything and read everywhere. Thanks to everyone who tried to help. I am gone.

  18. CounterDax
    Member
    Posted 9 years ago #

    I don't get any error messages... the pages wont load either as xml in the browser (IE, FireFox), or wont update the live bookmarks (FireFox) or do not show as RSS feeds (Safari). Nor does the RSS show in readers (such as the RSSblog widget). I'm using version 1.5.1 and 1.5.1.2.
    At first I thought it's a server problem since I am also unable to send trackbacks and pingbacks, but the RSS also doesn't work on my local XAMPP host in Mac OSX

  19. Momo Chama
    Member
    Posted 9 years ago #

    I don't know whats going on and unfortunately there is no help for my issue as of yet

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags