WordPress.org

Ready to get started?Download WordPress

Forums

FBF Facebook page Feed Widget
[resolved] Feed URL is no longer Valid (25 posts)

  1. matthewskeith
    Member
    Posted 10 months ago #

    My Facebook page ID is 133195256722159. When I plug that into the widget, I receive a "this feed is no longer valid. visit this page to find the new URL, if you have access:" error. The link is http://www.facebook.com/profile.php?id=133195256722159. The widget works with other Facebook page IDs that I have access to. I can't figure out why this page ID is different.

    Any help would be appreciated. Thanks,

    http://wordpress.org/plugins/fbf-facebook-page-feed-widget/

  2. lakshmananphp
    Member
    Plugin Author

    Posted 10 months ago #

    Hi

    Try replacing with other facebook page ID eg 422309087831636

    Your page has some restrictions. Its not publicly accessible. Pl check it.

    https://www.facebook.com/feeds/page.php?format=rss20&id=133195256722159

    Thanks
    Lakshmanan

  3. matthewskeith
    Member
    Posted 10 months ago #

    Hey Lakshmanan,

    I replaced it with the Facebook page ID you sent and it worked. I went to Facebook and looked at all of the settings for my page. It is set to publicly accessible. Here is a screenshot of my Facebook page settings:

    http://www.mattkeithdesigns.com/downloads/ss-1.png

    I can't see anything to suggest that the page would be private. It is publicly viewable on Facebook. What am I missing?

    Thanks,

    Matt

  4. daveykamm
    Member
    Posted 10 months ago #

    Hi there. I'm getting a similar error which is odd because it's been working perfectly since I installed it about 4 months ago. Just started seeing this the other day:

    Unable to fetch the feed
    Error :
    This XML document is invalid, likely due to invalid characters. XML error: Invalid character at line 113, column 29
    RSS Feed currently unavailable.

    screenshot here: http://screencast.com/t/neNrLRpD

    Thanks!

  5. lakshmananphp
    Member
    Plugin Author

    Posted 10 months ago #

    @matthewskeith

    Hi Matt,

    Try changing country restrictions. "Page is hown to everyone" is for all countries. Currently yours have restricted only to US.

    Let me know any issues.

    Thanks
    Lakshmanan

  6. lakshmananphp
    Member
    Plugin Author

    Posted 10 months ago #

    @davey

    Hi

    It seems your feed xml is invalid, Unicode may be the issue.

    Pl let me know your facebook page ID

    Thanks
    Lakshmanan

  7. daveykamm
    Member
    Posted 10 months ago #

    Hi. Thanks for your help. Page ID is: 222171201170254

    So strange that it just stopped working.
    Thanks!

  8. lakshmananphp
    Member
    Plugin Author

    Posted 10 months ago #

    Hi davey,

    A ? question mark in the feed description breaks the xml.

    Let me fix and update you soon

    Thanks
    Lakshmanan

  9. daveykamm
    Member
    Posted 10 months ago #

    Thanks!

  10. matthewskeith
    Member
    Posted 10 months ago #

    Hey Lakshmanan,

    Changing the country restrictions did the job. All is working now.

    Thanks!

  11. daveykamm
    Member
    Posted 10 months ago #

    Hey Lakshmanan - was wondering if you had any luck with a fix and/or is there anything I can do on my end?
    Thanks so much!!

  12. lakshmananphp
    Member
    Plugin Author

    Posted 10 months ago #

    Hi davey,

    Try the following fix.

    The plugin uses simplepie to fetch RSS feeds. But Simplepie requires valid XML.

    We cannot control facebook XML feed.

    So I have removed the illegal characters in SimplePie's parser.

    Now the feeds are working fine.

    Please follow the below instructions

    Go to your site File Manager or use any FTP software.

    The path is website/www/wp-includes/SimplePie/Parser.php

    Replace the file contents with http://pastebin.com/0zA9gXZe this updated file.

    Now check your FBF facebook page feed widget. It should work.

    Let me know if you have any issues.

    Thanks
    Lakshmanan

  13. daveykamm
    Member
    Posted 10 months ago #

    Hey Lakshmanan! That did the trick! Thank you SO much.

    -david

  14. grudder
    Member
    Posted 10 months ago #

    I'm having the same issue for a page I admin id: 118053973830

  15. grudder
    Member
    Posted 10 months ago #

    I've tried everything that's posted here, but it stills says "Facebook Syndication Error - This feed URL is no longer valid. Visit this page to find the new URL, if you have access"

  16. 808wonch
    Member
    Posted 9 months ago #

    Me too please help. When I put in your app id it works so what is wrong with my FB page that I need to fix or re-do???
    app ID:625294470824325

  17. jedifunk
    Member
    Posted 8 months ago #

    no offense, but this is the worst solution you could possible offer...

    you should NEVER, EVER, EVER hack WP core... and suggesting that users do so to get your plugin working is even worse.

  18. suparoku
    Member
    Posted 4 months ago #

    Similar problem just cropped up today. I replaced FBF with "Recent...Posts" but I prefer FBF. Did something happen to cause this to stop working today after working fine for three months or so?

    thanks

    Warning: strpos() expects parameter 1 to be string, array given in /home/javanon04/public_html/wp-includes/SimplePie/Content/Type/Sniffer.php on line 97

    Warning: substr() expects parameter 1 to be string, array given in /home/javanon04/public_html/wp-includes/SimplePie/Content/Type/Sniffer.php on line 99

    Warning: strpos() expects parameter 1 to be string, array given in /home/javanon04/public_html/wp-includes/SimplePie/Content/Type/Sniffer.php on line 97

    Warning: substr() expects parameter 1 to be string, array given in /home/javanon04/public_html/wp-includes/SimplePie/Content/Type/Sniffer.php on line 99

    Warning: strpos() expects parameter 1 to be string, array given in /home/javanon04/public_html/wp-includes/SimplePie/Content/Type/Sniffer.php on line 97

    Warning: substr() expects parameter 1 to be string, array given in /home/javanon04/public_html/wp-includes/SimplePie/Content/Type/Sniffer.php on line 99
    Unable to fetch the feed
    Error :
    A feed could not be found at http://www.facebook.com/feeds/page.php?id=681253421885683&format=rss20. A feed with an invalid mime type may fall victim to this error, or SimplePie was unable to auto-discover it.. Use force_feed() if you are certain this URL is a real feed.
    RSS Feed currently unavailable.

  19. Questionmarktarius
    Member
    Posted 4 months ago #

    Facebook is sending the wrong mimetype.

  20. grudder
    Member
    Posted 4 months ago #

    I've given up on this & found a better plugin for FB feeds. There's obviously no interest on the part of the developer to fix it. Suggesting we hack code that they wrote?? The whole reason I build in WP now is so I can hand off the site to the client when I'm done and not have to continue to do updates/changes. What is going to happen when an "update" for this plugin comes along (if it ever does)?

  21. Questionmarktarius
    Member
    Posted 4 months ago #

    There's not a whole lot a plugin update can do to fix the problem in SimplePie.

  22. suparoku
    Member
    Posted 4 months ago #

    If FB is sending the wrong mimetype, why would they change yesterday? Why does the other (Recent Facebook Posts) work when FBF does not work. Just curious.
    thanks

  23. Questionmarktarius
    Member
    Posted 4 months ago #

    The problem isn't with this plugin, but with the SimplePie reader.
    SimplePie is just too picky, and gives up when it gets a mimetype it doesn't expect. SimplePie does have a flag that tells it to ignore goofy mimetypes, but WP doesn't implement that flag.

    FBF FB widget is asking WP to get the feed, and WP is asking SimplePie to get the feed. SimplePie gives up (because WP didn't tell it not to), thus WP assumes the feed is broken, thus FBF FB Widget assumes the feed is broken.

    The other "broken" thread has a simple (but naughty) fix.

  24. acleach
    Member
    Posted 4 months ago #

    That would be this thread? http://wordpress.org/support/topic/feed-broken-2?replies=15#post-5285108

    SimplePie barfs because Facebook is including two Content-Type headers, which the W3C spec allows. SimplePie expects only one and is not coded to cope with more than one.

    Any widget which relies on SimplePie will fail with the current Facebook feed.

  25. MissVallentin
    Member
    Posted 3 months ago #

    My page is fully open for everyone, yet I can't get this plugin working...

    The ID is: 519952281428872

    And the error I get, is that the URL is no longer working....
    Please help!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.