WordPress.org

Ready to get started?Download WordPress

Forums

Feed Them Social
[resolved] "Feed Them" settings page not shown (5 posts)

  1. Emma Edgar
    Member
    Posted 3 months ago #

    Hello,

    I have an interesting problem. The shortcode generation page isn't showing up on one of my client's websites. First I tested the plugin on my sandbox site, and everything worked fine. Then I installed it on the client's site and the shortcodes page doesn't show. When I click on "Feed Them", it goes to system info and I don't see a way to get back to the main plugin page.

    I was able to add Facebook and Twitter feeds to the site by using the plugin on my site to generate the shortcodes I needed. So for now it's fine, but when I turn the site over to them, they'll need to be able to generate shortcodes themselves.

    Any thoughts?

    Thanks!
    Emma

    =============================================================================================
     Versions
    =============================================================================================
    Feed Them Social Plugin version: 	1.4.2
    WordPress version: 	WP            3.8.1
    Installed plugins: 	Gravity Forms by rocketgenius version 1.8.6, Advanced Custom Fields: Flexible Content Field by Elliot Condon version 1.1.1, Advanced Custom Fields: Options Page by Elliot Condon version 1.2.0, Advanced Custom Fields: Repeater Field by Elliot Condon version 1.1.1, Advanced Custom Fields by Elliot Condon version 4.3.5, Column Shortcodes by Codepress version 0.6.4, Debug Bar Actions and Filters Addon by Subharanjan version 1.4.1, Debug Bar Console by koopersmith version 0.3, Debug Bar Extender by Thorsten Ott, Automattic version 0.5, Debug Bar by wordpressdotorg version 0.8.1, DesktopServer for WordPress by Stephen Carroll version 1.4.0, Developer by Automattic version 1.2.5, DF Bootstrap Shortcodes by Dustin Filippini version 1.4.2, Easy FancyBox by RavanH version 1.5.6, Feed Them Social by SlickRemix version 1.4.2, Google Analytics for WordPress by Joost de Valk version 4.3.5, Gravity Forms CSS Ready Class Selector by Brad Vincent version 1.1, Image Widget by Modern Tribe, Inc. version 4.0.8, Jetpack by WordPress.com by Automattic version 2.9.2, Regenerate Thumbnails by Viper007Bond version 2.2.4, Rewrite Rules Inspector by Daniel Bachhuber, Automattic version 1.2.1, Soliloquy by Thomas Griffin version 1.5.7.1, Sucuri Security - SiteCheck Malware Scanner by Sucuri, INC version 1.5.6, User Switching by John Blackbourn version 0.8.8, Widget Manager Light by OTWthemes.com version 1.8, WordPress Importer by wordpressdotorg version 0.6.1, WordPress SEO by Joost de Valk version 1.5.2.5, WP Cleanupifier by Dustin Filippini version 1.0, WP Help by Mark Jaquith version 1.3, wpMandrill by Mandrill version 1.33
    
    =============================================================================================
     Server Environment
    =============================================================================================
    PHP Version: 	5.4.19
    Server Software: 	Apache
    WP Max Upload Size: 	50 MB
    WP Debug Mode: 	No
    fsockopen: 	fsockopen is ON

    https://wordpress.org/plugins/feed-them-social/

  2. Emma Edgar
    Member
    Posted 3 months ago #

    More info. I just tried accessing the page by adding "/wp-admin/admin.php?page=feed-them-settings-page" after the domain and it says Access Denied. I used the Advanced Access Manager plugin to look at the capabilities for my admin user, and it says I have access to everything and nothing is hidden.

  3. Emma Edgar
    Member
    Posted 3 months ago #

    Nevermind... Plugin conflict. A plugin disabled the Edit Plugins capability.

  4. Emma Edgar
    Member
    Posted 3 months ago #

    Sorry for all the messages...

    As I was trying to figure out how to disable the other plugin or modify it to not use define( 'DISALLOW_FILE_EDIT', true ); I found this in the codex: "Please note: the functionality of some plugins may be affected by the use of current_user_can('edit_plugins') in their code. Plugin authors should avoid checking for this capability, or at least check if this constant is set and display an appropriate error message. Be aware that if a plugin is not working this may be the cause."

    I'm not sure how you use the capability or why you check for it, but it would be appreciated if this could be changed somehow. Just a suggestion.

    Thanks!
    Emma

  5. slickremix
    Member
    Plugin Author

    Posted 3 months ago #

    Thanks for the heads up, we'll look into that on a future update.

Reply

You must log in to post.

About this Plugin

About this Topic