WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Feed down for podcast (28 posts)

  1. jaycking
    Member
    Posted 8 years ago #

    My podcast was not being updated in directories. I assumed I may have enterred wrong rewrite rule in .htaccess. Found I had not included a _, as outlined in codex on podcasting (under Dedicated Podcasts). When I added the _ my rss feed disappeared altogether. I changed it back, but feed did not return.

    Anybody have any idea how I messed up?

  2. URL please ...

  3. jaycking
    Member
    Posted 8 years ago #

    htpp://audiolingo.org

  4. popf
    Member
    Posted 8 years ago #

    cant' link!

  5. popf
    Member
    Posted 8 years ago #

    cant' link!

  6. In your sidebar, you have linked to your feed as:

    http://audiolingo.org/audiolingo.org/wp/feed

    This is, of course, wrong in a few ways. Currently, you do not have permalinks active, so your correct feed URL is currently this:

    http://audiolingo.org/wp-rss2.php

    If you did have permalinks active, the correct feed URL would be:

    http://audiolingo.org/feed/

    Now, as you can see, http://audiolingo.org/wp-rss2.php does have a bit of a validation problem:

    http://feedvalidator.org/check.cgi?url=http%3A%2F%2Faudiolingo.org%2Fwp-rss2.php

    I would recommend first replacing the wp-rss2.php file with a fresh copy from a new WordPress download. If that doesn't work, try replacing wp-feed.php, then your main index.php file, then your theme's header.php file. If neither of those work, disable all of your plugins and check your theme's validation again.

    Basically, that blank line and the "home/audikin8/www/wp-rss2.php" line are getting in there somehow, and they shouldn't be there. Blank lines in feeds can be caused by blank lines at the beginning or end of any WordPress file, but I have no idea how the "home/audikin8/www/wp-rss2.php" is getting in there.

  7. jaycking
    Member
    Posted 8 years ago #

    If you mean you can't link to the feed, I know. It's gone. I woke this morning to the whole site gone. Now it's back, but the feed is gone. Damn those insufferable feed eating gremlins!

  8. jaycking
    Member
    Posted 8 years ago #

    I'll try replacing those files.
    The wp/feed URL was a stab in the dark. The original feed URL, the one that was sent out to the directories, was wrong, I guess. It was http:/audiolingo.org/?feed=rss2&category_name=podcasts/. When it's all resolved, I'll apparently have to go back to each of the directories and give them the correct URL.

  9. When using the default theme, the correct feed URLs will always be listed in the footer. And, in most WordPress themes, the correct feed URLs should be listed at the top of your blog's source code. This is because these URLs are typically generated by dynamic PHP calls, which display the correct feed URLs as they apply to whatever permalink and directory structure you may have.

  10. jaycking
    Member
    Posted 8 years ago #

    I do run the default theme, but am unable to access the RSS entries. Firefox tells me it must run an external application. It hands the ball to Safari. Safari says I need Tiger and I'm running OSX 10.3. And call me ignorant (I am when it comes to computers) but I don't even know where my blog's source code is located.

  11. Ah, that's because the the little feed: in front of the feed URL. See this for an explanation and removal instructions: http://wordpress.org/support/topic/29291#post-164887

  12. jaycking
    Member
    Posted 8 years ago #

    Oh, Lordy. Ditched the rss, feed & index .phps, replaced them with fresh copies from a WP download. Changed the feed link to http://audiolingo.org/wp-rss2.php. The result: A feed, but it's rss version 0.92. The edit version reads as version 2.0, so I can't change it and affect any change at all. Now I'm really confused.

  13. Hm, no. Not sure where you saw that. http://audiolingo.org/wp-rss2.php is now a perfectly valid RSS 2.0 feed. The only problem that I can see now is that feed: still exists in front of the feed URLs in your footer. Edit your theme's footer.php file by following the instructions in the post that I linked to above.

    Also, you're currently running WordPress v1.5, which is quite a bit outdated, and I can't remember if there were any feed-specific bugs. You may want to upgrade to v1.5.1.3 just to make sure.

  14. jaycking
    Member
    Posted 8 years ago #

    Spent two hours performing an upgrade. Site's not exactly down, but..
    Take a look: http://audiolingo.org Index only.

  15. jaycking
    Member
    Posted 8 years ago #

    Am I to understand I need to upgrade from 1.5 to 1.5.1 to 1.5.2 to 1.5.3?? It'd take less time to repost all my entries for the last four months. That's how long it's been since I downloaded 1.5. Certainly WordPress hasn't gone through all those versions in four months, has it?

  16. No, you can go straight from v1.5 to v1.5.1.3. But, when you uploaded the main index.php file, you somehow managed to remove the ".php" from the end of it. Just append ".php" to the end of the index file in your root directory, and you'll be just fine.

  17. jaycking
    Member
    Posted 8 years ago #

    I restored the index to a .php and placed it in wp-admin where it belonged. I think I still have a problem with .htaccess, however. I deleted the contents as instructed in the codex, but forgot to save its contents. It's empty now.

  18. No, no. That index.php file belonged in your root directory ... I think. Either way, the problem is that you have no index file in your root directory, and that index file needs to be WordPress' index.php file. So, download WordPress again, expand it (if your system software does not do it automatically for you), take the first index.php file that you find after opening the new "wordpress" folder, and upload it to your site's root directory.

  19. jaycking
    Member
    Posted 8 years ago #

    Whoa! That did it, alright! Thanks, macmanx. Now, do I need anything in htaccess other than my rewrite rule for my podcast?

  20. jaycking
    Member
    Posted 8 years ago #

    Also, the link to the "feed" removal recipe said I should eliminate the word "feed" from the tag ">RSS in the sidebar .php. Trouble is, that line doesn't exist in the sidebar .php.

  21. Now, do I need anything in htaccess other than my rewrite rule for my podcast?

    You may want to enable "pretty permalinks" at some point. You can find more info on that here: http://codex.wordpress.org/Using_Permalinks If you do chose to enable permalinks, WordPress will automatically add the .htaccess rewrite rules for you, you will not have to manually add them. Also, by "rewrite rule for my podcast," I assume that you want to create a dedicated podcasting category. If that is the case, follow the instructions here: http://codex.wordpress.org/Podcasting#Dedicated_Podcasts (you will have to manually add these rules to your .htaccess file). If that is not the case, and your blog is just one big podcast, then your RSS 2.0 feed is your podcast feed.

    Also, the link to the "feed" removal recipe said I should eliminate the word "feed" from the RSS tag in the sidebar .php. Trouble is, that line doesn't exist in the sidebar .php.

    I know. In this post: http://wordpress.org/support/topic/41784#post-234893 I mentioned that you should remove it from footer.php.

  22. jaycking
    Member
    Posted 8 years ago #

    I'm not finding the word "feed" there either. I'll track it down later.
    A more pressing concern is what happens when I try to post, which is basically nothing. http://audiolingo.org/wp-admin/post.php gives me multiple error messages. Any ideas?

  23. I'm not finding the word "feed" there either.

    Go to the Presentation tab and select "Theme Editor", then click on your Footer Template. Now, find <a href="feed:<?php bloginfo('rss2_url'); ?>">Entries (RSS)</a> and remove "feed:" from it. IOW, change this:

    <a href="feed:<?php bloginfo('rss2_url'); ?>">Entries (RSS)</a>

    into this:

    <a href="<?php bloginfo('rss2_url'); ?>">Entries (RSS)</a>

    You can do the same for the comments feed right next to it.

    ... gives me multiple error messages.

    Please quote the "multiple error messages."

  24. jaycking
    Member
    Posted 8 years ago #

    I failed to read the error messages closely yesterday. Seems I had neglected to import the menu.php. I did so today and as a result can post.

    I removed the word feed and its colon from the footer template, for both Entries and Comments. They still appear in front of both lines on the site. Could they be somewhere else in the code as well? It's actually not a big deal, as the URL appears in the bottom menu bar (or whatever it's called) anyway. But I do wonder why that change did not bring about, uh... change.

    One more thing. There's no edit link in my entries. Shouldn't there be?

  25. jaycking
    Member
    Posted 8 years ago #

    Edit tags have returned.

  26. jaycking
    Member
    Posted 8 years ago #

    Thanks for all your help, Macmanx.

  27. Not a problem! Should I assume that everything is now working correctly?

    P.S. If you have not upgraded to v1.5.2 yet, please do so as soon as you can. It's a security and bug-fix update, and was released a few hours ago.

  28. jaycking
    Member
    Posted 8 years ago #

    Everything seems aok.
    Boy, these upgrades come fast and furious around here. Give me a few days. Going from 1.5 to 1.5.? about winded me.

Topic Closed

This topic has been closed to new replies.

About this Topic