WordPress.org

Ready to get started?Download WordPress

Forums

Google Calendar Events
[resolved] Feed Cannot be Displayed (19 posts)

  1. Adam
    Member
    Posted 1 year ago #

    After installing the plugin, and setting up a "public" Google Calendar in my Gmail account, this is the error message I get in my site:

    1 or more of your feeds could not be displayed. The following errors occurred:

    Feed 1: Access to this feed was denied (403). Please ensure you have public sharing enabled for your calendar.

    I made sure that the Google Calendar is public. I'm also using this shortcode within the WP Editor:

    [google-calendar-events id="1" type="ajax" title="Events on" max="25"]

    Any ideas why the feed can't be read?

    http://wordpress.org/extend/plugins/google-calendar-events/

  2. Ross Hanney
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Adam,

    In the sharing settings for the calendar (in Google Calendar), do you have the "Share only my free/busy information (Hide details)" option enabled or disabled? It needs to be disabled for the plugin to work correctly.

  3. Adam
    Member
    Posted 1 year ago #

    Thanks for your quick response, Ross!

    Looks like the option you mentioned is enabled. Here's what my calendar sharing options currently are set at: http://adambaney.com/wp-content/uploads/ss-20121228.png

    Under "Make this calendar public", the only available option is "See only free/busy (hide details)".

  4. Adam
    Member
    Posted 1 year ago #

    I unchecked (disabled) the "Make this calendar public" option, reloaded the page in my site, and I got the same error message (even after clearing my cache).

  5. Ross Hanney
    Member
    Plugin Author

    Posted 1 year ago #

    Ah, you're using Google Apps calendar?

    You'll need to log in as an admin to the main domain dashboard for the Apps account, then go to the calendar settings. Set both of the "External sharing options..." settings (under "Org Settings" and "General") to "Share all information, but outsiders cannot change calendars".

    Then, go back to the sharing settings for your calendar (as shown in your screenshot). You should now be able to select "See all event details" from the drop-down box.

  6. Adam
    Member
    Posted 1 year ago #

    I am using the Google Apps Calendar. The calendar now works, but I had some trouble getting it to work. I had to log out, then log back in for some of the settings to become available. Unfortunately, my "test" calendar disappeared completely. I had to re-create it entirely. This was only a test calendar, so I had only 4 events to re-create. Not a big deal. I just hope that when I make these changes on the "real" calendar, the "real" calendar doesn't disappear also.

    The calendar is now functioning as it should. Thank you very much for your help, Ross! I really appreciate it!

  7. Ross Hanney
    Member
    Plugin Author

    Posted 1 year ago #

    I'm glad you got it working. The disappearing calendar is odd, though.

    The plugin will also work with the private feed URL for a calendar (which doesn't require adjusting sharing settings, if you're worried about losing the "real" calendar), but bear in mind that events marked as private would show up in the plugin (not the case with the public URL).

  8. Adam
    Member
    Posted 1 year ago #

    Good to know that the "private feed URL" will also work with your plugin. Thanks for clarifying the difference! I really appreciate your help.

  9. BrendaSargeant
    Member
    Posted 1 year ago #

    Hi there, I'm lost on this part:

    You'll need to log in as an admin to the main domain dashboard for the Apps account, then go to the calendar settings. Set both of the "External sharing options..." settings (under "Org Settings" and "General") to "Share all information, but outsiders cannot change calendars".

    I don't see this: "External sharing options..." settings (under "Org Settings" and "General") to "Share all information, but outsiders cannot change calendars"." anywhere?

  10. Adam
    Member
    Posted 1 year ago #

    @BrendaSargeant - You'll first have to log into Google Apps, https://google.com/a/ to manage your domain.

    These settings are under Settings > Calendar > Org Settings and Settings > Calendar > General.

    Select this option for Org Settings, "External Sharing options for primary calendars":
    > "Share all information, but outsiders cannot change calendars"

    Select this option for General, "External Sharing options for secondary calendars":
    > "Share all information, but outsiders cannot change calendars"

  11. BrendaSargeant
    Member
    Posted 1 year ago #

    When I do that, I don't have a Settings option appear? Is it under the gear icon? Because when I click the gear icon, it shows nothing under it :(

  12. Adam
    Member
    Posted 1 year ago #

    Could be you don't have Google Apps. You may have just a regular Gmail account set up. Could you confirm that you can sign in to Google Apps to "manage your domain"?

    1. Go to https://google.com/a/
    2. Click "Sign In"
    3. Enter your domain
    4. Select "Domain management" from the drop-down
    5. Click "Go"
    6. Sign in to your Gmail-based email (with the account that has administrator access to manage the domain)
    7. When you see the Dashboard, click "Settings" and make sure "Calendar" is selected in the left-hand sidebar. You will now see the "Org Settings" and "General" tabs there.

    Let me know if this set of instructions gets you to Google Apps.

  13. BrendaSargeant
    Member
    Posted 1 year ago #

    Thank you so much for trying to help me!

    I get to step 5 all good.
    Step 6, I choose gmail from the list and sign in
    Step 7...not sure by dashboard what you mean? When I sign into my gmail, that is where it takes me, my gmail. Calendar is up top, I can choose it there, but I just end up back where I started?

    :(

  14. BrendaSargeant
    Member
    Posted 1 year ago #

    Is the Settings I'm looking for under the gear icon? Because my gear icon doesn't work, shows a drop down with nothing, can't click it or anything.

  15. Adam
    Member
    Posted 1 year ago #

    If you are using Google Apps, you should see "Manage this domain" under the gear icon in your Gmail email account (See screen shot link below). If it isn't there, then either (1) you probably don't have Google Apps, or (2) a different email address for your domain has access to Google Apps.

    Manage this domain screen shot:
    http://s24.postimg.org/5k6s88q6d/gmail_manage_this_domain.png

    From my step-by-step instructions, did you select "Domain management" from the Google Apps sign-in drop-down? See screen shot below. If you selected that, you should be taken to the right place (whether you're signed in to Google before or after this step).

    Domain management screen shot:
    http://s23.postimg.org/b5gc9tkl7/gapps_domain_management.png

  16. BrendaSargeant
    Member
    Posted 1 year ago #

    :(

    Yes, following the step by step I selected Domain Management from the drop down like in the screenshot.Then I signed in there. It lists My Services with gmail, drive, calendar, etc. If I try to click on the gear icon on the top right hand corner here, its an empty drop down. Nothing at all.

    So...assuming you mean sign into my gmail email from this list of my services page, I do that. It takes me to my gmail email. I click the gear icon and have these options:

    Display Density (with the 3 options)
    Settings
    Send Feedback
    Help

    This shouldn't be so hard, should it? :(

  17. Adam
    Member
    Posted 1 year ago #

    Your issue is 1 of 2 things: (1) You don't have Google Apps access with that email, or (2) you don't have Google Apps at all.

    The screen shot below is from a Gmail account that does not have Google Apps Domain Management capability:

    http://s13.postimg.org/4a992gkuf/gmail_no_googleapps_management.png

    In either case, you won't see the options (at least not with the email account you're trying to use) above from my original / initial posting discussion.

  18. BrendaSargeant
    Member
    Posted 1 year ago #

    Hi!!!

    So after asking the client for the 3rd time...sure enough there was another login :)

    All that....and I had the wrong log in.

    So sorry, but thank you SO much for your help and patience. After getting the correct login, I went through your steps and it worked perfectly. Thanks again, I really appreciate it.

  19. Adam
    Member
    Posted 1 year ago #

    @BrendaSargeant - You're very welcome. Glad it's working now!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic