WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Featured images not showing on WordPress Multisite website (2 posts)

  1. santanin
    Member
    Posted 1 year ago #

    Hello. I recently moved to a Multisite, and now all the Featured Images in the site, the pages, the widgets, etc. no longer display. The full-sized images of those featured images display fine...it's just the Featured Images that no longer appear on the site. I have tried removing the images as featured images, and setting them again, but it still does not work.

    I have read that two common causes are the TimThumb script and the httpd.conf file. The theme is NOT using the TimThumb script, so it has nothing to do with that. And I can say that my .htaccess file definitely is being read fine, as if I make some changes to it I break the entire site, so it has nothing to do with having to modify the httpd.conf file.

    What else could cause this?

    As an example, the home page of my site displays a large image that I set as the Featured Image of that page. However, it does not display. The site's logo, which is just a regular image (not set as a featured image) works fine.

    The URL of the broken featured image for the home page is something like this (the dt-slash is the name of theme):

    http://mydomain.com/subfolder/wp-content/themes/dt-slash/resize.php?get_image=/files/2012/03/homepageimage.jpg&no_limits=true

    The URL of the logo that works fine is this:

    http://mydomain.com/subfolder/files/2012/03/logo.png

    My .htaccess file is this:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    
    # END WordPress

    I have never touched any of the site settings in WordPress.

    Would someone be so kind to assist me in this problem?

    Thank you for your time.

    - Nate

  2. No. Making a new post is not correct :)

    http://wordpress.org/support/topic/featured-images-no-longer-working-in-multisite?replies=6

    I'll un-resolve it. We can just say 'Nope, not time thumb' and keep working.

Topic Closed

This topic has been closed to new replies.

About this Topic