WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Facebook: Advanced Social SEO for WordPress
[resolved] Featured Images no longer show up on Facebook (10 posts)

  1. elmalak
    Member
    Posted 8 months ago #

    Hi,
    I just noticed that whenever I post an article of my website to Facebook or use the sharing tools, my featured images don't show up and I can only see that default grey image displayed with my articles.

    Here is an example,
    http://www.elmalakrx.com/Arabic/medical_info/%d8%a3%d8%af%d9%88%d9%8a%d8%a9-%d8%b9%d9%84%d8%a7%d8%ac-%d8%a7%d9%84%d8%a5%d9%83%d8%aa%d8%a6%d8%a7%d8%a8.htm

    Things used to work just fine before, not sure what happened or when did it happen.

    Hope you can help me get this fixed.

    Much appreciated.

    http://wordpress.org/plugins/nextgen-facebook/

  2. JS Morisset
    Member
    Plugin Author

    Posted 8 months ago #

    You haven't switched on debug mode.

    Here's the image info on that page:

    <!-- og:image:1 --><meta property="og:image" content="http://www.elmalakrx.com/Arabic/wp-content/uploads/2013/10/antidepressants-400x205.jpg"/>
    <!-- og:image:1 --><meta property="og:image:height" content="205"/>
    <!-- og:image:1 --><meta property="og:image:width" content="400"/>

    And the FB debugger says:

    https://developers.facebook.com/tools/debug/og/object?q=http%3A%2F%2Fwww.elmalakrx.com%2FArabic%2Fmedical_info%2F%25D8%25A3%25D8%25AF%25D9%2588%25D9%258A%25D8%25A9-%25D8%25B9%25D9%2584%25D8%25A7%25D8%25AC-%25D8%25A7%25D9%2584%25D8%25A5%25D9%2583%25D8%25AA%25D8%25A6%25D8%25A7%25D8%25A8.htm

    js.

  3. elmalak
    Member
    Posted 8 months ago #

    Hi,
    Sorry about forgetting to turn on the debug mode, I've just done it now.

    I see it's working for this one but for lots of the others it isn't whereas it used to work for all of them before, I really don't know if this was one of the latest updates or what?

    As you can see for this one for example it's not working,
    https://developers.facebook.com/tools/debug/og/object?q=http%3A%2F%2Fwww.elmalakrx.com%2FArabic%2Far_questions%2Fquestion_1018.htm

    Any idea why?

    Regards,

  4. JS Morisset
    Member
    Plugin Author

    Posted 8 months ago #

    NgfbMedia                 :: get_content_images       : 2 x matching <img/> html tag(s) found
    	NgfbMedia                 :: get_content_images       : match 0: img src="http://www.elmalakrx.com/Arabic/wp-content/uploads/2011/05/exubera-instructions.jpg"
    	NgfbMedia                 :: get_content_images       : src image rejected: width and height attributes missing or too small (468x177)
    	NgfbMedia                 :: get_content_images       : match 1: img src="http://0.gravatar.com/avatar/ad516503a11cd5ca435acc9bb6523536?s=100"

    exubera-instructions.jpg was too small, so the gravatar image was used instead.

    js.

  5. JS Morisset
    Member
    Plugin Author

    Posted 8 months ago #

    FYI - The next version will warn of image that are too small. You may want to give it a shot:

    http://downloads.wordpress.org/plugin/nextgen-facebook.6.19rc7.zip

    js.

  6. elmalak
    Member
    Posted 8 months ago #

    Thank you again.

    So, where do I get to set the image size so it works with my existent images as it did before?

    Also, should I use the next version you provided on a live site or is it not stable enough yet?

    Regards,

  7. JS Morisset
    Member
    Plugin Author

    Posted 8 months ago #

    Have a look at the Image Dimensions option on the Open Graph+ General settings page.

    v6.19.0 was released yesterday.

    js.

  8. elmalak
    Member
    Posted 8 months ago #

    Thanks for the update.
    I've installed it and I can now see the warning on the edit post.

    I've setup the image size under General Settings to 325*210 but still some thumbnails aren't working when I shared it to Facebook although the meta tag preview seems to pull the right image info.

    This is the page I am referring to.
    http://www.elmalakrx.com/Arabic/ar_questions/%D9%87%D9%84-%D8%A7%D9%84%D8%A8%D8%A7%D8%B1%D8%A7%D8%B3%D9%8A%D8%AA%D8%A7%D9%85%D9%88%D9%84-%D8%A2%D9%85%D9%86-%D8%AA%D9%85%D8%A7%D9%85%D8%A7%D9%8B-%D9%84%D9%84%D8%A3%D8%B7%D9%81%D8%A7%D9%84.htm

    Also, I wanted to know, does the plugin resize the thumbnails each time I change the default image size under General settings?

    Many thanks.

  9. JS Morisset
    Member
    Plugin Author

    Posted 8 months ago #

    Works for me - when I share that URL, the correct image is displayed.

    If you have Auto Resize checked, then yes, it will create images of the correct size (otherwise image sizes are only created during the upload process).

    js.

  10. elmalak
    Member
    Posted 8 months ago #

    I am a bit confused with this, but thank you for your care and support anyway.

    Regards,

Reply

You must log in to post.

About this Plugin

About this Topic