WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
[resolved] Featured Image not working in Twenty Eleven theme (8 posts)

  1. talbot649
    Member
    Posted 1 year ago #

    Hi there,

    I've got a strange problem with a site running WooCommerce. I've imported around 14,000 products successfully and the site is working and launched.

    The problem occurs with around a thousand or so products. The featured image wasn't included in the original import (even though it was included in CSV file), so I'm trying to manually edit each product and perform a fix.

    On these products, I can select Featured Image and upload or select one from the library, however once I click the 'Set Featured Image' button it's not there...

    Tried over and over, also with different products, still no joy. It allows me to add an image to the Product Gallery but that's no use...

    If anyone could help I'd really appreciate it.

    http://wordpress.org/extend/plugins/woocommerce/

  2. Sean6m
    Member
    Posted 1 year ago #

    Having the same issue, can select the featured image but when you click "set featured image" it just goes back to the edit product page without adding the image?

  3. talbot649
    Member
    Posted 1 year ago #

    Exactly right - what's that all about?

    Did you add your products individually or through a bulk upload?

  4. talbot649
    Member
    Posted 1 year ago #

    I've got a feeling this may be an issue with the latest update. I added a Featured Image to another woocommerce site this morning with no problems. I updated my plugins (including woocommerce) and then I couldn't add a Featured Image afterwards...

    Have the plugin authors experienced this too?

  5. harshasbc
    Member
    Posted 1 year ago #

    Dear friends Just try disable all plugins expect woo commerce. if you used smart manager 3.1.2 sure plug in code clash with featured image

  6. Sean6m
    Member
    Posted 1 year ago #

    That was the problem harshasbc, the Smart manager 3.1.2 as soon as it was disabled the featured images started to work without issues, thank you.

  7. talbot649
    Member
    Posted 1 year ago #

    Yes, that fixed it for me too. Smart Manager is the dirty factor in all of this!

  8. harshasbc
    Member
    Posted 1 year ago #

    Please follow these steps to fix this issue:

    Go to file 'smart-manager.php' located at 'wp-content/plugins/smart-manager-for-wp-e-commerce'
    Go to line number 105 OR look for this code:
    // Including Scripts for using the wordpress new media manager
    if (version_compare ( $wp_version, '3.5', '>=' )) {
    define ( 'IS_WP35', true);
    wp_enqueue_media();
    wp_enqueue_script( 'custom-header' );
    }
    Replace it with following code:
    // Including Scripts for using the wordpress new media manager
    if (version_compare ( $wp_version, '3.5', '>=' )) {
    define ( 'IS_WP35', true);
    if ( isset( $_GET['page'] ) && ( $_GET['page'] == "smart-manager-woo" || $_GET['page'] == "smart-manager-wpsc" ) ) {
    wp_enqueue_media();
    wp_enqueue_script( 'custom-header' );
    }
    }
    Save the file. That's it!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.