WordPress.org

Ready to get started?Download WordPress

Forums

Featured Image not visible on front end of site (14 posts)

  1. archtop
    Member
    Posted 6 months ago #

    Hello

    This is my first ever post and I'm not a programmer, just an ex-graphic designer - so please don't tear me to shreds! I'm attempting to move an existing site (created in Dreamweaver a few years ago) to WordPress.

    It seems I am failing at the first hurdle. I installed WP and am using MAMP on a macbook to build the site on a localhost. I did this before on another site and it worked fine. However, this time I'm running into problems with the Featured Image function. I can browse and insert in the usual way but the image will not appear when I preview the page.

    I tried this on a test page on my other site which is live (not on a localhost) and the feature is working using the same image. I deactivated the two plugins I installed and that didn't help. I also tried installing different themes. I'm using a static front page as well but I don't see why it should make a difference. So I'm thinking it is something to do with the localhost setup.

    Any ideas folks???
    Thanks in advance,
    John

  2. Pioneer Valley Web Design
    Member
    Posted 6 months ago #

    Even though the featured image section may appear in the editor, the theme template used for your front page needs to call that function. This makes this theme dependent. What theme are you using?

  3. archtop
    Member
    Posted 6 months ago #

    Thanks for taking the time to reply. At the moment I'm using Attitude by Theme Horse. I tried other themes and the same problem. That's why I was thinking it might be something to do with the local file storage on my machine. When i insert images onto a page, they preview fine.

  4. Pioneer Valley Web Design
    Member
    Posted 6 months ago #

  5. archtop
    Member
    Posted 6 months ago #

    Ok, i'll follow up with Theme provider but, like I mentioned, the problem is not theme specific. it persists when i change theme on the local host.

    I don't think it is a pages issue as I can add featured image to a page on my other site.

    The second link you posted is interesting - perhaps there is a problem with 'the loop' Pity i can't code! oh well, i'll keep trying...

  6. Pioneer Valley Web Design
    Member
    Posted 6 months ago #

    I don't think it is a pages issue as I can add featured image to a page on my other site

    Are both sites using the same theme/version and WordPress/version?

  7. David Radovanovic
    Member
    Posted 6 months ago #

    Just in case, check that you have GD and/or imagick php libraries installed.

  8. archtop
    Member
    Posted 6 months ago #

    Both sites are wordpress 3.8

    Where would I see the GD / imagick php libraries? i looked in Appearance editor but didn't see them there. I've no coding experience - sorry!

  9. David Radovanovic
    Member
    Posted 6 months ago #

    Several different places depending on your server configuration. Though most fequently php mods installed can be found by the output of phpinfo.php file, which should reside somewhere on your server that is NOT publically accessible.

  10. David Radovanovic
    Member
    Posted 6 months ago #

    Are the images appearing in your media library? And, if so can you sucessfully use the new media/image Edit function to rotate, resize or crop the images in your media libray?

  11. Pioneer Valley Web Design
    Member
    Posted 6 months ago #

    You said:

    Both sites are wordpress 3.8

    I asked:

    Are both sites using the same theme/version and WordPress/version?

    Are both sites running the same theme? post_thumbnail support is setup in the theme. Please review what I have already linked you to related to this.

    If unsure, you can use Pastebin to share the template file used by each site to display the front page and we can take a peek. I realize you noted you had changed themes, that does not mean any of the themes tested were setup to use the post_thumbnail, featured image.

    Without knowing what theme(s) you are using we are spinning our wheels...

  12. archtop
    Member
    Posted 6 months ago #

    Thanks, you are right. I just switched to the Attitude theme on the live site and inserted a Featured image. It's not working. I was aiming for a large full-width image just under the main Navigation, just like the Attitude demo page. Here is the page I just created (with Featured image active) http://www.johnmoriartymusic.com/guitars-2/

  13. Pioneer Valley Web Design
    Member
    Posted 6 months ago #

    Did you get the theme from wordpress.org or Theme Horse (where we see upgrade to Pro button)? What Demo are you referring to? Do you mean the thumbnail view of that theme are seen here??:

    http://wordpress.org/themes/attitude

    And, if you do mean that, is that not a featured post slider included with theme using theme options (is it available in Free Theme?).

    Ask here:

    http://wordpress.org/support/theme/attitude

  14. archtop
    Member
    Posted 6 months ago #

    Downloaded the theme directly from the Wordress dashboard.

    Yes, the thumbnail view you pointed out is the one I was trying to re-create.

    I don't know if it is a featured post slider. i looked under theme options and there's reference to many features including featured post / page slider.

    I will do as you suggested and ask this question in the theme's support pages. I will ask 'can the sample page illustrated in the WordPress themes section ( http://wordpress.org/themes/attitude ) be reproduced with the Theme's free version and, specifically, can I use the featured post field to add a large image as illustrated.

    I'll get back once i get an answer.
    Thanks!

Reply

You must log in to post.

About this Topic