WordPress.org

Ready to get started?Download WordPress

Forums

Customizr
Featured Image not showing up... (11 posts)

  1. liasuzuki
    Member
    Posted 1 year ago #

    Hi,

    Anyone know why my featured images aren't showing up with customizr? They show up as thumbnails for related posts, but not for the post itself when you view it.

    http://aksb.org

    Thanks,

    Lia

  2. Mayur vekariya
    Member
    Posted 1 year ago #

    did you set featured image while post?

  3. liasuzuki
    Member
    Posted 1 year ago #

    Thanks for the reply, Mayur. Are you asking if I set the featured image in the post itself? If so, yes, I did.

  4. Mayur vekariya
    Member
    Posted 1 year ago #

    No there is separate options for set a featured image.
    You have to set there image by size 50x50,150x150 whatever your requirement.

    If you did not set the featured image then it will take automatically from post.but,here is problem comes if image size is not appropriate for the featured image then it will not show.

    you have to set relevant sized image for better feature image display.

    check out this plugin "Auto Post Thumbnail".

  5. liasuzuki
    Member
    Posted 1 year ago #

    Thanks, Mayur. I remember seeing that once, but can't find it now. Can you tell me where I might find it? Or do you mean for each individual page/post?

  6. liveland
    Member
    Posted 1 year ago #

    Lia, I was having the same problem on my blog, but I've just worked out how to fix it by editing the file called content.php (within Appearance -> Editor) and changing the following code:

    <?php if(is_single() || is_page())
    echo '<hr class="featurette-divider">';
    ?>

    to:
    <?php if(is_single() || is_page())
    if ( has_post_thumbnail() ) {
    the_post_thumbnail();
    }
    echo '<hr class="featurette-divider">';
    ?>

    Now my featured images are showing up on my posts, I hope this helps you to resolve your problem.

    Hopefully the developers of this great theme will add this functionality as standard in the future (or maybe make it an optional setting).

  7. liasuzuki
    Member
    Posted 1 year ago #

    Thanks so much! But now I need code to keep it to a max say, 200px so I don't have to manually set the size of each of our 600+ pages/posts.

    Any idea how I do that?

  8. liasuzuki
    Member
    Posted 1 year ago #

  9. Mayur vekariya
    Member
    Posted 1 year ago #

    In your post image size may by too much larger.that cant set as a featured image so you have to set manually for that post.

    for set featured image for individual post check this: http://www.screenr.com/q7c

  10. liasuzuki
    Member
    Posted 1 year ago #

    Ok, now thumbnails are showing up perfectly for my posts, but not on my pages. I'm assuming I use a similar code to the one above...? And then also, I don't know where to put it.

    Ex: This page has a thumbnail, but nothing shows up... http://aksb.org/about/instructor/chris-ziliotto-teaching-apprentice/

    Thanks...

  11. liasuzuki
    Member
    Posted 1 year ago #

    Argghh... Just updated Customizr and now my thumbnails aren't showing up again. @liveland, the code you gave me before worked, but now I don't know where to paste it in because everything changed.

    Any suggestions...?

    Thanks,

    Lia

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic