WordPress.org

Ready to get started?Download WordPress

Forums

Hupso Share Buttons for Twitter, Facebook & Google+
featured image not shared on facebook (13 posts)

  1. sannevanschie
    Member
    Posted 8 months ago #

    Hello,
    I noticed featured image is not used when somebody shares a post on Facebook. It has to be at least 200 px in both directions.
    My standard featured image is smaller but i do have a large version witch is 300 x 225, can i set hupso to use that image for facebook?

    the_post_thumbnail('large')

    http://wordpress.org/plugins/hupso-share-buttons-for-twitter-facebook-google/

  2. kasal
    Member
    Plugin Author

    Posted 8 months ago #

    Can you post URL of your blog?

    You cannot use a separate featured image just for Hupso. Hupso, by default uses 'medium' version of the thumbnail which should be up to 300px x 300px if your original featured image is big enought.

  3. PDIuserr
    Member
    Posted 8 months ago #

    Does the featured image only show when someone shares a post on Facebook or will it work with any of the social icons?

  4. kasal
    Member
    Plugin Author

    Posted 7 months ago #

    Image is defined in og:image meta tag so it should also be used by other social networks.

  5. PDIuserr
    Member
    Posted 7 months ago #

    Thank you for your response. I can see the meta tag in the code on the post page.
    <meta property="og:image" content="http://www.mycompany.com/blog/wp-content/uploads/2013/12/image-name-420x263.jpg"/><meta name="generator" content="WordPress 3.7.1" /> but it only shows the image with the post for Facebook. I have Twitter, G+ and Linkedin social icons on the page as well. Under the settings for "Image for Facebook thumbnail", I have "Featured image of post" selected. I do have a featured image with each post but it looks like it is selecting the medium sized image (as you stated in another post) which is fine with me.

  6. fontanasteve
    Member
    Posted 7 months ago #

    Hi there,

    A not dissimilar experience here with this. I have updated the settings in Hupso to use the featured image on posts/pages but it is only showing the Header logo image when trying to share to Facebook. In the "Use thumbnail" dialogue on the share page, only the header image is shown, (Image 1 of 1)

    Using Responsive theme.

    Thanks

    Steve

    Sorry, I should have added that the post on the site is at: http://www.financialadviceinspain.es/site/diversification-with-investments-can-pay-dividends/

  7. kasal
    Member
    Plugin Author

    Posted 7 months ago #

    This error is shown by Facebook Debugger:

    Provided og:image is not big enough. Please use an image that's at least 200x200 px. Image 'http://financialadviceinspain.es/site/wp-content/uploads/2013/08/JohnHaywardLogo1.png' will be used instead.

  8. gigi.gleason
    Member
    Posted 6 months ago #

    I'm experiencing a similar issue. The featured image shows in the appropriate share link except for the Facebook Share button. My site is http://www.epicureanadventurer.com Thanks for helping me resolve this issue.

  9. spwolf32
    Member
    Posted 6 months ago #

    I am having the same issues as those above with the facebook button. I have even chosen a larger image and made it the featured image to no avail.

    Please help.

    Link to page in question : http://qualitypianoservice.net

    Thank you for your help.

  10. kasal
    Member
    Plugin Author

    Posted 6 months ago #

    @gigi.gleason: Facebook shows both images when you sahre your post. You can select which one to use by clicking arrows.

    @spwolf32: The image in your og:image tag is this http://qualitypianoservice.net/wp-content/plugins/all-in-one-seo-pack/images/default-user-image.png. And this one is shown when sharing to Facebook. Make sure that you use FCH under "Image for Facebook thumbnail" in plugin settings.

  11. spwolf32
    Member
    Posted 6 months ago #

    @kasal I did as you instructed. Still Facebook shows default image though FCH is chosen.

  12. kasal
    Member
    Plugin Author

    Posted 5 months ago #

    It seems that you og:image tag is handled by All in One SEO Pack. You should configure the proper image there.

  13. tisha12
    Member
    Posted 5 months ago #

    My website is http://www.welovethegirls.com and none of my featured images post to Facebook using Hupso Share Can someone please help me with this?

Reply

You must log in to post.

About this Plugin

About this Topic