WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Featured Image not Publicizing Correctly on Facebook (3 posts)

  1. justalillost
    Member
    Posted 10 months ago #

    I know there have been many posts on this already but none of them seem to resolve my issue.
    I have a featured image and it still doesn't post correctly on the Facebook page when I publicize it.

    Even when I copy and paste the link into the Facebook page status, the images that it lets me scroll through strangely don't include the featured image. It includes all the ones I have on my sidebar of the main page and other images within my post but not the actual featured image. Going through this way, I have to "upload image" from the Facebook page.

    When I click on "Share to Facebook" from my post, same thing - it gives me options to scroll through images, but none of them include my actual featured image.

    my site is http://justalillost.com
    and my facebook page is https://www.facebook.com/justalillost

    An example of where this occurred is with this post: http://www.justalillost.com/2013/10/inaccurate-realities-is-a-reality/
    and how it publicized onto the Facebook page: https://www.facebook.com/justalillost/posts/729413350408769

    Thanks

    http://wordpress.org/plugins/jetpack/

  2. DylangerBravo
    Member
    Posted 10 months ago #

    I too am having a similar problem. I wasn't having the problem until about a week or so ago, now instead of posting my post's featured image, It just posts the websites main header image. I haven't changed anything on my site as far as pics, plugins, etc. that could have made it change.

  3. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 10 months ago #

    When you share a post on Facebook, or when Jetpack Publicize publishes a post to your Facebook page, Facebook crawls the page and looks for Open Graph meta tags in the head to build a complete post preview (with an image, title, description, ...).

    You can see what Facebook sees by entering one of your posts' URLs in Facebook Debugger:
    https://developers.facebook.com/tools/debug

    @justalillost The Facebook Debugger doesn't return any errors for the URL you provided as an example. I'm afraid I cannot really explain why Facebook chose to ignore the image meta tags provided with your post when you published it.

    Other blog owners have reported similar issues in the past few days, and some of them experienced the Facebook bug reported here:
    https://developers.facebook.com/bugs/483025408453290

    it might be what happened on your site too. It might be worth using the Facebook Debugger with some of your posts to see if you can reproduce the bug.

    @DylangerBravo Could you let me know your site URL so I can take a look at the issue on your site? You can also use the Facebook debugger to run the tests by yourself.

    Thanks!

Reply

You must log in to post.

About this Plugin

About this Topic