WordPress.org

Ready to get started?Download WordPress

Forums

Boot Store
Featured Image not displaying in post (5 posts)

  1. csweths
    Member
    Posted 11 months ago #

    Hi,

    Love your theme. Fits my bill completely but have one small fix that needs to be addressed for me to completely switch to this theme.
    I am able to upload "Featured Image" from the
    "Edit Page" area but the same is not displaying in the front end on publishing. I am using the "Default Template".

    How should I get this done.

  2. csweths
    Member
    Posted 11 months ago #

    HI,
    I have resolved this.
    Add the following code to either single.php or page.php depending on where you want the featured image to be displayed.
    <?php get_the_post_thumbnail( $post_id, $size, $attr ); ?>
    <?php the_post_thumbnail( $size, $attr); ?>

    Now how to I move the position of the image? to Center. I got the following code but how to I integrate it with the above code?

    <?php the_post_thumbnail('thumbnail', array('class' => 'aligncenter')); ?>

  3. Jezebel Philips
    Member
    Posted 11 months ago #

    Hi,

    I had the same issue but am obviously far less experienced with using code than you. I copied and pasted your code into the bottom of the boot strap php page and now I'm getting a parse error message which is locking me out of wordpress altogether :(

    *If* I manage to get my site back, I would like to give this another shot. Would you be a star and tell me please, exactly where (in newbie terms) did you put that code?

    Thanks,

    Louisa

  4. sur
    Member
    Theme Author

    Posted 11 months ago #

    Hi,
    You can do it without coding.
    Theme compatibility > How to display single content.
    Note you can set up by post type, securely you only want to be applied for posts or pages because product pages have template tag to display images.

    Best Regards

  5. Thorned Rose
    Member
    Posted 11 months ago #

    @sur - Theme Compatibility only works if you are using TCP. If you don't have it or have another ecommerce plugin, the problem remains.

Reply

You must log in to post.

About this Theme

About this Topic