WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Featured image meta-box not displaying in WP 3.1 (16 posts)

  1. moun
    Member
    Posted 3 years ago #

    Hey,

    I really hope someone can help me with this :-)

    After i upgraded mu wordpress-installation to 3.1, the featured image-box has disappeared. If i mark the featured-image-box in screen-options, i still can't get it to display. I have tried to deactivate all plugins, and it still doesn't work.

    I have allowed post-thumbnails in functions.php.

    Is anyone aware of this problem - can't seem to find anything on it on Google/this forum.

    Thanks for your help :-)

  2. After i upgraded mu wordpress-installation to 3.1, the featured image-box has disappeared.

    3.1 hides some screen options on posts & pages edit screens by default. Just turn on the ones you want.

    More info here: http://ottopress.com/2011/wp-quickie-metaboxes/

  3. Also go to Network Admin -> Settings and enable the image upload box.

    If this is disabled it also disables the featured image meta box.

  4. Also try switching to the TwentyTen theme. You may have a conflict in your functions.php file.

  5. johnpent
    Member
    Posted 2 years ago #

    I was having the same issue. Followed Andrea_r's advice and it fixed it.

    I usually check that little box off and allow the upload, but did not.

    Thanks for this string! Saved me pulling out some excess hair.

    John

  6. Frankie Jarrett
    Member
    Posted 2 years ago #

    @Andrea_r you just saved my life.

    i was freaking out, triple checking my add_theme_support and register_post_type functions until i found your little gem comment, thank you :)

    //Frankie

  7. :)

    You're welcome. At one point there was a yellow alert message for this, but I don't know if it was removed or not.

  8. Frankie Jarrett
    Member
    Posted 2 years ago #

    yep, it's gone. who knows how long it would have driven me crazy had I not known what to search in the forums. it's hard to search for, every answer was about how to turn them on via functions and no info (other than yours!) regarding that obscure multisite setting.

    I'd vote to get that alert turned back on :)

    //Frankie

  9. emarchak
    Member
    Posted 2 years ago #

    Like the others, @Andrea_r just saved my life. Thanks so much!

  10. Clement35
    Member
    Posted 2 years ago #

    hi there, really sorry about that but i do not find this damn check box. i'm pretty sure it's not that far, and it's driving me insane!

    i can see the yellow warning telling me to enable uploads on that screenshot :
    http://codex.wordpress.org/images/9/93/superadmin-options.png

    but still can't find the checkbox.
    Please help me out on this one!
    thxs

  11. It's not a logical thing.

    See the three boxes at the bottom for 'Images' 'Videos' and 'Music'?

    Check the box for images.

  12. Clement35
    Member
    Posted 2 years ago #

    hoh hohooooooo... man am i dumb!
    i was expecting something more obvious. thxs a million!

    works like a charm now.

  13. mzlock
    Member
    Posted 2 years ago #

    I'm having the same issue, but I don't have the same settings, as I'm working with a single WordPress install and not Multi-site like in Clement35's picture. So, I can't find where to change the uploader settings. I assume this is what I need to do, since it worked for so many others. Where can I find this setting?

    Using WordPress 3.2.1 with the Striking theme and the Custom Post Type I made using the Custom Post Type UI does not have the Featured Image box shown. I did add the code to enable post-thumbnails for my theme.

  14. mzlock - Please make a new topic for this, as you don't have the same problem. You're not using MULTISITE so this is not the forum section for you :)

  15. pebblegirl
    Member
    Posted 2 years ago #

    Where is Network admin -> Settings??

  16. esmi
    Theme Diva & Forum Moderator
    Posted 2 years ago #

    @pebblegirl: It is impolite to interrupt another poster's thread. Please post your own topic.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.