WordPress.org

Ready to get started?Download WordPress

Forums

Featured Video Plus
Feature Video Image Not working on WP-Critique Theme (2 posts)

  1. elvinf
    Member
    Posted 1 year ago #

    Hi,
    I have the WP-Critique theme installed. I can't see to get the feature image to show up as a video instead of an image.

    When "Replace Feature Image" is selected it returns nothing. no thumbnail no video. When its disabled it return a static screenshot of the video. Any reason's why this wouldn't be working.

    -E

    http://wordpress.org/extend/plugins/featured-video-plus/

  2. Alexander Hoereth
    Member
    Plugin Author

    Posted 1 year ago #

    I guess (I have no access to the code) the theme does not make use of the default the_post_thumbnail function as it is intended to be used. The plugin hooks into it to display the video. If the theme juggles around with the code returned by this function it might break the video and therefor nothing is being displayed. To still use the plugin you need to manually edit the theme's source files (index.php and single.php/single-post.php in most cases) and add something like the following conditional function:

    <?php if( has_post_video() ) { ?>
    <?php the_post_video(); ?>
    <?php } else { ?>
    <?php // default code to display the Featured Image goes here ?>
    <?php } ?>

    Sorry there is no more straight forward way. Many of the paid frameworks and paid themes do not make use of the WordPress functions but provide their own functions - other people already reported similar problems. For the automatic featured image replacement the plugin relays on the post thumbnail functions which ship with the WordPress core.

    You bought the theme - maybe support is included? They for sure could tell you where you would need to insert the above code. Without access to the code I cannot do so my self..

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.