WordPress.org

Ready to get started?Download WordPress

Forums

The Events Calendar
[resolved] FEATURE REQUEST - No Scroll on Google Maps API (8 posts)

  1. Darius
    Member
    Posted 1 year ago #

    The option to toggle on and off the ability to use the mouse scroll to zoom in and out on the Google Maps API would be beneficial.

    In the current situation, the user scrolls down to read more about the event, running into the map on the way down. The user's downward scrolling is interrupted when the cursor hits the map and it begins to zoom out.

    A simple "scroll to zoom" toggle would fix the problem.

    Thank you.

    http://wordpress.org/extend/plugins/the-events-calendar/

  2. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    This raises a really good point - let me get a member of the dev team to take a look at this request and see if it's planned to be addressed in 3.0 (and if not, what it'd take to get it added to the feature list). I'll keep you posted on what I hear back...thanks for the tip!

  3. Darius
    Member
    Posted 1 year ago #

    Thank you.

    If you look at heatmaps of how a single event page is used (when a full width map is in place) the user's cursor is consciously brought to the left or right side of the page before they begin to scroll (usually right), "requiring" them to move out of the way. This helps show the positive potential of adding the scrolling on/off toggle.

  4. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    Definitely makes a good point. Should have a response here over the next 24 hours, so I'll certainly relay what I've got at that point.

  5. roblagatta
    Modern Tribe Support
    Plugin Author

    Posted 1 year ago #

    Hey again dsalehipour. I talked with our lead dev Paul on this, and after some digging we found a similar thread on this same point...which provided a fix you may find valuable. Check it out: http://tri.be/support/forums/topic/turn-off-auto-scrolling-on-google-maps/.

    That help get you where you want to be? Let me know if not. Meanwhile I've also gotten the ball rolling internally on discussions around making this a general setting on the site's backend. No guarantees, but we end up deciding to go that route you'll see it in a future release.

  6. Barry Hughes
    Member
    Plugin Author

    Posted 1 year ago #

    All set here dsalehipour?

  7. Darius
    Member
    Posted 1 year ago #

    Hey again dsalehipour. I talked with our lead dev Paul on this, and after some digging we found a similar thread on this same point...which provided a fix you may find valuable. Check it out: http://tri.be/support/forums/topic/turn-off-auto-scrolling-on-google-maps/.

    That help get you where you want to be? Let me know if not. Meanwhile I've also gotten the ball rolling internally on discussions around making this a general setting on the site's backend. No guarantees, but we end up deciding to go that route you'll see it in a future release.

    Thank you for your responses!
    The directions in the link you posted have worked!

    Just find the "the-events-calendar/admin-views/event-map.php" file and edit the first function:

    Before Editing:

    function initialize() {
    	var myOptions = {
    	    zoom: <?php echo tribe_get_option( 'embedGoogleMapsZoom', '10' ); ?>,
    	    center: event_address,
    	    mapTypeId: google.maps.MapTypeId.ROADMAP
    	};

    After Editing:

    function initialize() {
    	var myOptions = {
    	    zoom: <?php echo tribe_get_option( 'embedGoogleMapsZoom', '10' ); ?>,
    	    scrollwheel: false,
    	    center: event_address,
    	    mapTypeId: google.maps.MapTypeId.ROADMAP
    	};

    All set here dsalehipour?

    Yes all set!

  8. jonahcoyote
    Member
    Posted 1 year ago #

    Hi Darius,

    Glad you got this all worked out. If there's anything else you need, please let us know.

    Thanks,
    Jonah

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic