WordPress.org

Ready to get started?Download WordPress

Forums

[closed] feature req: Media View: Default View & Image Size (17 posts)

  1. fishnyc22
    Member
    Posted 1 year ago #

    Hello wonderful WordPress Developers!

    I LOVE a lot of the new features of WP 3.5 but the media gallery is crippling my site. Defaulting to "All Media Items" on an image heavy site pretty much locks of the screen for quite some time before you can even click on the dropdown to switch it to "uploaded to this post" which "SHOULD" be the default selection. What makes it worse is that its loading the FULL size images making the load times even smaller. In my case, i'm dealing with high res files (2-8MB) that are there for generating printable PDFs.

    I've been scouring the forums trying to find a way to hack this so that "Uploaded to this post" is the default (without using javascript after the page has loaded to SWITCH the selection in the drop down... which still causes the big delay).

    The Media View should really default to "Uploaded to this post" and it should load in a Medium thumbnail at the most. Anything more than that is slowing things down. Please please please consider this change.

    thanks for all that you do!

    Dave

  2. jtm21
    Member
    Posted 1 year ago #

    I completely agree with this – especially the way it'll load the full size images in the media gallery view. I just registered on the forum specifically to raise this point!

    Above all I really think WP should load a small thumbnail version anyway, it just makes no sense loading massive full size images when thumbnail versions are available and the available image size is always constrained by the design of the dashboard anyway.

    So big +1 from me.

  3. fishnyc22
    Member
    Posted 1 year ago #

    I was able to temporarily solve this via help from a great plugin editor.

    I had some help from the great Sewpafly who develops Post Thumbnail Editor Plugin. He shared a great piece of JS that prevents the load of ALL MEDIA ITEMS and forces it to load only images "UPLOADED TO THIS POST" by default.

    https://gist.github.com/anonymous/5588893

    I dropped that into a JS file and called it in functions.php with the admin_enqueue_scripts. See GIST above for both the PHP and JS.

    Works brilliantly. Hopefully the fine wordpress folks fix this in an upcoming update, but for now Sewpafly has the best solution I've found. Thanks again buddy. Hope this helps some other fine folks out there.

  4. jtm21
    Member
    Posted 1 year ago #

    great! thanks for sharing!

  5. fishnyc22
    Member
    Posted 1 year ago #

    Glad to help!

    I should mention that I have just discovered that the Media Viewer defaults to MEDIUM sized images which I had disabled (set to 0,0) since I was not using that size and preventing bloat. When medium size isn't available wordpress loads the FULL size image. That was really slowing things down... I have since given in enabled the medium size and generating all the images. (bummer).

  6. jtm21
    Member
    Posted 1 year ago #

    Interesting!

    I didn't think it was possible to disable the generation of the default "medium" images?

  7. fishnyc22
    Member
    Posted 1 year ago #

    yes if you set them to w/h of 0 they will not generate them. I have 1000's of images so it was a way to prevent unnecessary images.

  8. fishnyc22
    Member
    Posted 1 year ago #

    Sorry, use this GIST the other had a bug. Also made the other as anonymous and couldn't change it by accident.

    https://gist.github.com/fishnyc22/5593693

  9. Matic
    Member
    Posted 11 months ago #

    +1 on this
    I am having the EXACT same issue and my images get always loaded in full size and not medium which is set to 300 x 300 which I think is the default value.

    BIG Thanks for the temporary solution but in my case I often do check all images and browsing them is terrible.

  10. Hansaplastique
    Member
    Posted 11 months ago #

    +1 here as well ...

    When I'm writing a post I 99% of the time really do not need to see "ALL" media, just the ones I'm uploading to the post that I'm writing.

    p.s. If I need to see more, I'll be using the search function - maybe that's a modification worth mentioning as well; when using search - show (optionaly) all that match.

  11. arronlee
    Member
    Posted 10 months ago #

    Yup indeed, it is really great. But before I got the help of WP3.5, I have only checked the free trial package of an imaging tool to view and resize images and do as its tutorials about how to create web-based image viewer or how to create Windows image viewer using C#.NET. But I have to admit that the processing way of WP3.5 is simple and fast. It can save us a lot of time. Thanks for all your efforts you have devoted!

    Best regards,
    Arron

  12. yarcod
    Member
    Posted 10 months ago #

    I am having the same problem as well.

    Earlier I used a wordpress.com free blog, but decided that I wanted it on my own server. There everything worked the way I wanted it to, but now, using WP 3.6, all images are shown in full size all the time. Is there anyone who knows of a more permanent solution to this in 3.6?

    I am quite new to WP, so please give me a thorough explanation if you have one :)

    Best regards,
    Daniel

  13. esmi
    Forum Moderator
    Posted 10 months ago #

    @yarcod: As per the Forum Welcome, please post your own topic.

  14. hansharhoff
    Member
    Posted 8 months ago #

    I just wanted to clarify the application of the patch by fishnyc22
    because it took me quite some time to apply it correctly:
    The files that you need to create/patch are wp-content/themes/NAME_OF_YOUR_THEME/functions.php
    and then you want to put the admin.js script in wp-content/themes/NAME_OF_YOUR_THEME/javascripts/
    (or possibly change the line too look in js/ instead of javascripts and put it in js/)

    Thank you for the patch.

  15. mayuxi
    Member
    Posted 8 months ago #

    WordPress 3.7.1. Same issue. Full images are loading as thumbnails in media library. Is there any fix for this so far?

  16. fishnyc22
    Member
    Posted 8 months ago #

    mayuxi. Did you disable (or set medium to 0,0 size). It defaults to a medium image and if its missing it uses the full size. So if thats the case you need to add the medium images and rebuild them using the ajax rebuild thumbnails plugin.

  17. mayuxi
    Member
    Posted 8 months ago #

    Thanks. I set it to 150 to 150 (same as mini thumbnails), and will check how it works in future.

    I don't need extra "medium images", since I have own setup in functions.php.

Topic Closed

This topic has been closed to new replies.

About this Topic