WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] feature in sub dir (17 posts)

  1. everest19
    Member
    Posted 4 years ago #

    Hello every body

    I have 2 subdirectory and testing to be able show the inserted photos in the features story, but they are shows only in the main site. And it is not strange because when I uploade a picture in the mysite.com it saves in content/uploads but in the other cases they save in content/blogs.dir/1/files etc. How can I do to show pictures in my subdirectory. Please help me

    Best Regards

  2. everest19
    Member
    Posted 4 years ago #

    hi!

    Have anybody an idea to solv this problem?

  3. everest19
    Member
    Posted 4 years ago #

    Please help

  4. And it is not strange because when I uploade a picture in the mysite.com it saves in content/uploads but in the other cases they save in content/blogs.dir/1/files etc.

    Default behaviour.

    The main blog will save its pic in the uploads directory, the extra sub-blogs will use numbered folders under the blogs.dir directory.

    But you have given enough details or even links that we can visit to try and help. :)

  5. everest19
    Member
    Posted 4 years ago #

    my site is borderlessnews.com and one of the sub is borderlessnews.com/danish

  6. everest19
    Member
    Posted 4 years ago #

    sorry, and my theme is comfy plus

  7. everest19
    Member
    Posted 4 years ago #

    hello Andrea

    I am waiting to help, Please help

  8. I'm guessing the theme is using the timthumb script to generate the thumbnails. If so, then the call to that in the theme itself will need to be fixed.

    http://www.binarymoon.co.uk/2009/10/timthumb-wordpress-mu/

  9. everest19
    Member
    Posted 4 years ago #

    sorry

    what are you mean with the call in....? I am not good in php, what and where must I write+

    best regards

  10. Then you'll need to ask the theme designer. :)

  11. everest19
    Member
    Posted 4 years ago #

    Thanks I have send 15e e mail to deluxe theme which I have bough my theme, but they never answer.

    Thank you very much

  12. tdjcbe
    Member
    Posted 4 years ago #

    We talked about it a few months ago:

    http://mu.wordpress.org/forums/topic/15800

    Not sure if this is the same issue but it was using an out of date function call.

  13. everest19
    Member
    Posted 4 years ago #

    MR Andrea

    I wonder if I send you the codes of my theme and timthumb you can help me please. I have send meny e-mail to deluxe but they do not answer.

    Best Regards

  14. kris42
    Member
    Posted 4 years ago #

    I found my problem !! I didn't understand correctly the word above it means before

    I didn't put at the correct place the code in wp-config.php

    It seems working .. Thanks for all your helps..

  15. @everst - it's Mrs Andrea, thanks. ;)

    Sorry, can't help.

  16. everest19
    Member
    Posted 4 years ago #

    Mrs Andrea
    As you wrote my theme use timthumb and I have been trying to modify it with the codes you showed me, without any result!!!
    In my theme(comfy) I have builtin-function which has two codes aboat thumb as folow.

    can you please tell me which one must be change and how?

    Best Regards

    creating thumbnails
    ********************************************************************/
    function show_thumb($w,$h,$zc,$cropfrom,$q) {

    global $post;
    preg_match_all('/\< *[img][^\>]*src *= *[\"\']{0,1}([^\"\'\ >]*)/',get_the_content(),$matches);
    $thumb = get_post_meta($post->ID, 'thumb', true);

    if ($thumb) {
    print '<img src="'.get_bloginfo('template_directory').'/thumbs/timthumb.php?src='.$thumb.'&w='.$w.'&h='.$h.'&zc='.$zc.'&cropfrom='.$cropfrom.'&q='.$q.'" alt="'.str_replace('&', '&', $post->post_title).'" title="'.str_replace('&', '&', $post->post_title).'" />';
    } elseif (count($matches[1]) > 0) {
    print '<img src="'.get_bloginfo('template_directory').'/thumbs/timthumb.php?src='.$matches[1][0].'&w='.$w.'&h='.$h.'&zc='.$zc.'&cropfrom='.$cropfrom.'&q='.$q.'" alt="'.str_replace('&', '&', $post->post_title).'" title="'.str_replac'&', '&', $post->post_title).'" />';
    } else {
    // no custom key, no images, show nothing
    }

    }

    /********************************************************************
    creating thumbnails (no permalink to story, image only)
    ********************************************************************/
    function show_thumb_only($w,$h,$zc,$cropfrom,$q) {

    global $post;
    preg_match_all('/\< *[img][^\>]*src *= *[\"\']{0,1}([^\"\'\ >]*)/',get_the_content(),$matches);
    $thumb = get_post_meta($post->ID, 'thumb', true);

    if ($thumb) {
    print '<img src="'.get_bloginfo('template_directory').'/thumbs/timthumb.php?src='.$thumb.'&w='.$w.'&h='.$h.'&zc='.$zc.'&cropfrom='.$cropfrom.'&q='.$q.'" alt="'.str_replace('&', '&', $post->post_title).'" title="'.str_replace('&', '&', $post->post_title).'" />';
    } elseif (count($matches[1]) > 0) {
    print '<img src="'.get_bloginfo('template_directory').'/thumbs/timthumb.php?src='.$matches[1][0].'&w='.$w.'&h='.$h.'&zc='.$zc.'&cropfrom='.$cropfrom.'&q='.$q.'" alt="'.str_replace('&', '&', $post->post_title).'" title="'.str_replace('&', '&', $post->post_title).'" />';
    } else {
    // no custom key, no images, show nothing
    }

    }

  17. everest19
    Member
    Posted 3 years ago #

    Hello Mrs Andres

    I wrot the files wich I have in my comfy, Please tell me where must I add the codes that you recommend.

    Best Regards

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags