WordPress.org

Ready to get started?Download WordPress

Forums

Preference Lite
[resolved] Feature images NOT displaying on Pages with side bar (9 posts)

  1. JenQ
    Member
    Posted 1 year ago #

    I'm new to wordpress and have selected your template that seems to allow custom headers. I assumed that meant on Pages (with side bars) it would display feature images that I have selected for each page.
    The following is the page that is not displaying the feature image: http://comptechwest.com/?page_id=37

    Does anyone know what I'm doing wrong or have suggestions on what to look for to fix problem?

  2. StyledThemes
    Member
    Theme Author

    Posted 1 year ago #

    Hi JenQ,
    What I did with Preference Lite is coded the WP Custom header only for the front page. However, there is a widget position for the Showcase header which can be used instead and this will show up on "every" page, including your front page, unless you use a plugin such as Dynamic Widgets to manage where it's shown in your site. My Pro version of Preference gives you one additional showcase header position for your inner pages if you want to use the WP Custom header for the front page, but use the static image option with widgets (or even sliders) in the "Banner" position (not on the Lite version of Preference).

    But, for the Lite version, using the widget method to load an image in the Showcase position will show up on all pages, but the WP Custom Header is just on the Front Page.

  3. JenQ
    Member
    Posted 1 year ago #

  4. StyledThemes
    Member
    Theme Author

    Posted 1 year ago #

    You should be able to achieve a different image in the showcase header of each page by inserting an image (via html) into a text widget (which I recommend the Advanced Text Widget Plugin (lets you publish the widget on select locations and even disable the title), or using the Advanced text widget along with the Dynamic Widgets plugin (which also lets you publish to where you want. Doing this will allow you to have different images on different pages when you use the Showcase widget position.

  5. yolswan
    Member
    Posted 11 months ago #

    Hi,

    I really like your theme but I'm also having trouble with the header not showing on all pages. I tried the widget with a link to my main banner, but all I can see on my site is the actual html link, and not the image.

    Can you please help me with this? Thanks!

  6. StyledThemes
    Member
    Theme Author

    Posted 11 months ago #

    you want to double check that the code you use is something like this:

    <img src="link-to-your-image.jpg" alt="description" />

  7. yolswan
    Member
    Posted 11 months ago #

    Thanks for the prompt reply! When I use just that code, I see only the description on the showcase, but still not the image.

    Please advise.

    Thanks!

  8. yolswan
    Member
    Posted 11 months ago #

    Sorry, I had placed an extra letter on the link and that's why it wasn't working. It works now, but it shows double on the home page. How do I fix that?

    Thanks!

  9. yolswan
    Member
    Posted 11 months ago #

    I fixed it with the Advanced Text Widget plugin. Thanks!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic