WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Feature Image in FP using Publicize (3 posts)

  1. martineaeschli
    Member
    Posted 9 months ago #

    Hello,

    I'm having problems with the Feature Images when I use Publicize in FB.

    It works sometime but not always...

    I'm using a child made with twentytwelve

    I run this post with FB debugger and it showed me the exact image I wanted to be posted and it did not showed me anything wrong :
    http://www.scrapdeco.com/blog/kit-inspiration-carterie-suite-et-fin/

    but inside Facebook We did not have the right image ?

    https://www.facebook.com/Scrapdeco?hc_location=stream

    when I run the main page of the blog (the home) with FB debugger it tells me :

    Inferred Property The 'og:image' property should be explicitly provided, even if a value can be inferred from other tags.

    If I look at my code, I can see that my features images for home are 200x200 I put them now with 250x250. Will it be enough ?

    I'm a litlle lost with this FB feature !! when it works sometime...

    http://wordpress.org/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 8 months ago #

    When you share a post on Facebook, or when Jetpack Publicize publishes a post to your Facebook page, Facebook crawls the page and looks for Open Graph meta tags in the head to build a complete post preview (with an image, title, description, ...).

    Jetpack automatically adds these image tags for you, but doesn't add any image tag on the home page. To add your own image tag on the home page, you can follow the instructions here:
    http://jetpack.me/2013/07/12/add-a-default-image-open-graph-tag-on-home-page/

    I run this post with FB debugger and it showed me the exact image I wanted to be posted and it did not showed me anything wrong :
    http://www.scrapdeco.com/blog/kit-inspiration-carterie-suite-et-fin/

    but inside Facebook We did not have the right image ?
    https://www.facebook.com/Scrapdeco?hc_location=stream

    Other blog owners have reported similar issues in the past few days. Unfortunately, there isn't much we can do about this; once you've added the Open Graph meta tags to your site (and you've done so with Jetpack), it's up to Facebook to use them to build the post previews or to ignore them.

    If you keep experiencing this issue in the next few weeks, it might be worth letting the Facebook developers know about it here:
    https://developers.facebook.com/bugs

    Thanks!

  3. martineaeschli
    Member
    Posted 8 months ago #

    Ok thanks a lot for your prompt answer and for the advise. I know know that I did not anything wrong ...

    If it continues, I will report to FB ! It is so annoying when the result is so random !

Reply

You must log in to post.

About this Plugin

About this Topic