WordPress.org

Ready to get started?Download WordPress

Forums

WP Facebook Open Graph protocol
[resolved] FB suddenly not scraping URL (3 posts)

  1. 21CB
    Member
    Posted 8 months ago #

    Pasted a link from my site into Facebook and it came up without a description or thumb. Sudden change, perfectly fine before. Put it into lint and get this:

    Scrape Information
    Response Code 403

    Critical Errors That Must Be Fixed
    Bad Response Code URL returned a bad HTTP response code.

    Errors that must be fixed
    Missing Required Property The og:type property is required, but not present.

    Open Graph Warnings That Should Be Fixed
    Inferred Property The 'og:url' property should be explicitly provided, even if a value can be inferred from other tags.
    Inferred Property The 'og:title' property should be explicitly provided, even if a value can be inferred from other tags.

    Is this to do with this plugin? Nothing on my site has changed; all working fine. When I view page source the og values are all there.

    If you need to view the site, it's http://21stcenturyburlesque.com

    Any help appreciated.

    http://wordpress.org/plugins/wp-facebook-open-graph-protocol/

  2. Chuck Reynolds
    Member
    Plugin Author

    Posted 8 months ago #

    Well the site seemed to load fine for me and the source looks good; as in the plugin is doing what it's supposed to be doing.

    As for the response code.. perhaps your server is having some issues or throwing wrong codes?? 403 is a forbidden. http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html

    http://web-sniffer.net/ is showing a 200 (all good) code too but idk what FB scraper is seeing.

    Do note however that Facebook CONSTANTLY changes things and their debugger is typically more bugged than most things they have. I only know that because of having this plugin and everybody thinking the plugin is broke when it's FB scraper being lame.

    I'd say just file a support request with your host... tell them to look into it. and link them to the debugger. and see what they say.

    Cheers man!

  3. 21CB
    Member
    Posted 8 months ago #

    Host says everything fine/nothing changed. So must I conclude Facebook have suddenly changed the way they scrape? Very frustrating being stumped on this. Wondering what else I can try, even though nothing has changed on my end...

Reply

You must log in to post.

About this Plugin

About this Topic