WordPress.org

Ready to get started?Download WordPress

Forums

Favicon Trouble (4 posts)

  1. Mr VW
    Member
    Posted 7 months ago #

    Hello,
    I have read several posts on this issue and they all say to add code like this:

    <link rel="icon" href="<?php bloginfo('siteurl'); ?>/favicon.ico" type="image/x-icon" />
    <link rel="shortcut icon" href="<?php bloginfo('siteurl'); ?>/favicon.ico" type="image/x-icon" />

    OK, great, so i did that and still no joy. It appears in the admin side of the site, but not in the real world.

    site: http://www.kjscreations.co.nz
    WP Version 3.6
    Icon is at http://www.kjscreations.co.nz/favicon.ico (a red bow).

    Please can anyone see what I'm doing wrong here?

  2. kevinhaig
    Member
    Posted 7 months ago #

    try switching to favicon.png and using a .png file instead. It seems to work better in all browsers.

  3. Mr VW
    Member
    Posted 7 months ago #

    same issue sorry. Works in admin but not the 'outside'

  4. Rod Whiteley
    Member
    Posted 7 months ago #

    When I visit your site I see the icon on Firefox's tab. However, I only see the icon link in your HTML, not the shortcut icon link.

    I have had a lot of trouble adding favicons to my own sites, because Firefox caches the icons. The icon cache is separate from the main browser cache. When I add a new icon, Firefox is reluctant to update its cache. I use an extension called SQLite Manager to delete the cached icon from Firefox's places database.

Reply

You must log in to post.

About this Topic