WordPress.org

Ready to get started?Download WordPress

Forums

Favicon throwing 500 Internal Server Error with Multisite (33 posts)

  1. Josh Stauffer
    Member
    Posted 2 years ago #

    I'm running WP 3.1.3.
    Sub-directory multisite install.
    Root: http://www.themeweaver.net/demo/

    This URL is giving a 500 Internal Server Error: http://www.themeweaver.net/demo/graceful/wp-content/themes/graceful/images/favicon.ico

    This URL is not: http://www.themeweaver.net/demo/wp-content/themes/graceful/images/favicon.ico

    Any ideas what might be causing this error?

  2. This URL is giving a 500 Internal Server Error: http://www.themeweaver.net/demo/graceful/wp-content/themes/graceful/images/favicon.ico

    That URL is wrong. It's got the theme folder name *before* /wp-contet/ as well as after.

    What code are you using to generate it? Cuz it wouldn't work in a single site either.

  3. Josh Stauffer
    Member
    Posted 2 years ago #

    It's a child theme I built for Genesis. This site is named Graceful which uses the Graceful child theme.

    Site: http://www.themeweaver.net/demo/graceful/

  4. Josh Stauffer
    Member
    Posted 2 years ago #

    Perhaps it's a rewrite problem. The favicon is not accessible from both URL's but the stylesheet, for example, is...

    http://www.themeweaver.net/demo/graceful/wp-content/themes/graceful/style.css

    http://www.themeweaver.net/demo/wp-content/themes/graceful/style.css

    Any help is appreciated!

  5. The URL is right, Andrea, he's got it installed in the physical folder /demo/ AND named the site /graceful/ so the site URL would be themeweaver.com/demo/graceful :)

    Interestingly. If you go to http://www.themeweaver.net/demo/graceful/wp-content/themes/graceful/images it will REDIRECT YOU to http://www.themeweaver.net/demo/wp-content/themes/graceful/images

    Yeah. Something in your .htaccess is munging this up.

  6. Josh Stauffer
    Member
    Posted 2 years ago #

    @Ipstenu, Here's the contents of my .htaccess.

    RewriteEngine On
    RewriteBase /demo/
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule  ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
  7. That's the whole thing? Nothing in the root folder one up from Demo that may be affecting things?

    Do you have hotlink protections ?

  8. he's got it installed in the physical folder /demo/ AND named the site /graceful/ so the site URL would be themeweaver.com/demo/graceful :)

    darn it... lemme go see if we get the same thing going on with this other theme demo site I have.

  9. I'm wondering if it's because the site name as a subfolder is the same as the theme folder name.

    Got another site where the slug is slightly different than the theme folder?

  10. Josh Stauffer
    Member
    Posted 2 years ago #

    @Ipstenu, The .htaccess in one folder up looks pretty standard...

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  11. Josh Stauffer
    Member
    Posted 2 years ago #

    @Andrea_r, Here's with a differing slug and theme name...

    Internal Server Error: http://www.themeweaver.net/demo/tester/wp-content/themes/genesis/images/favicon.ico

    Working: http://www.themeweaver.net/demo/wp-content/themes/genesis/images/favicon.ico

    Thanks for the support guys.

  12. Can you double check the permissions AND the owner of that favicon file?

    Down under does the same thing.

    So /demo/ is the main site in the network, yes?

  13. Josh Stauffer
    Member
    Posted 2 years ago #

    Correct, /demo/ is the main site in the network.

    This file is 644 and has the same owner & group as the other files.

    Comparisons:
    * http://www.themeweaver.net/demo/graceful/wp-content/themes/graceful/images/favicon.ico
    * http://www.themeweaver.net/demo/graceful/wp-content/themes/graceful/images/enews.png

  14. Ron Rennick
    MultiSite Guru
    Posted 2 years ago #

    There may be something in your apache config specific to ico files that's triggering that.

    Your rewrite rules are correct & the file is physically there, so it's definitely something in your web server config.

  15. Josh Stauffer
    Member
    Posted 2 years ago #

    @Ron Rennick, Perhaps you are right but what I don't understand is that if it were an issue with Apache config, it should apply to all .ico files, right?

    Sorry if I am pasting too many URL's... only trying to demonstrate the issue.

    Not Multisite:
    Good: http://www.joshstauffer.com/wp-content/themes/josh_stauffer/images/favicon.ico
    Good: http://www.mandystauffer.com/joshstauffer.com/wp-content/themes/josh_stauffer/images/favicon.ico

    Multisite: (Main site in network: /demo/)
    Bad: http://www.themeweaver.net/demo/graceful/wp-content/themes/graceful/images/favicon.ico
    Bad: http://www.mandystauffer.com/themeweaver.net/demo/graceful/wp-content/themes/graceful/images/favicon.ico
    Notice, below, I removed the site slug graceful from the URL.
    Good: http://www.themeweaver.net/demo/wp-content/themes/graceful/images/favicon.ico
    Good: http://www.mandystauffer.com/themeweaver.net/demo/wp-content/themes/graceful/images/favicon.ico

    Thanks!

  16. Your good ones for the multisite install are all off the main site, not any of the SUB sites. that much we've already determined.

  17. Josh Stauffer
    Member
    Posted 2 years ago #

  18. Note the SP site uses subdomains, not subfolders. :)

  19. Josh Stauffer
    Member
    Posted 2 years ago #

    That was precisely my point. ;-)

  20. I appologize in advance for the site content (it's safe for work...)

    http://consensualreality.net/ponywars/wp-content/themes/ponywars/favicon.ico is a subfolder site with pretty much teh SAME setup as Josh. Sitename is ponywars, THEME name is /ponywars/

    The ICO file is just fine at http://consensualreality.net/ponywars/wp-content/themes/ponywars/favicon.ico AND http://consensualreality.net/wp-content/themes/ponywars/favicon.ico

    So the odds are it's NOT WordPress, but something weird in your apache settings and how it handles redirects.

    By the way, looking at http://www.press75.com/themes/roundabout/wp-content/themes/roundabout/images/ - there IS no favicon.ico so of COURSE that link is 'bad' ;)

  21. Josh Stauffer
    Member
    Posted 2 years ago #

    @Ipstenu, But there is a difference between your example and mine. The difference is where the multisite install resides.

    Your example:
    http://example.com/site/wp-content/

    My example:
    http://example.com/multisite/site/wp-content/

    And you are right about the press75 example not containing a ico. Good find. ;-)

    Sorry if I seem off my rocker but I'm really baffled by this.

    If it were the apache settings, why would some favicon.ico's display while others do not?
    PLUS image files display using the same path. Would they not fall under the same redirect rules as the .ico?

  22. Josh Stauffer
    Member
    Posted 2 years ago #

    @Everyone, please understand that I'm not trying to be stubborn here. If you all firmly believe it is apache config related and not perhaps a bug in WP, I'll rest my case.

    For what it's worth, I'm using HostGator. I'm going to try a similar setup on my localhost and on a GoDaddy account I have access to.

    Thanks thus far!

  23. Yeah, I know it's not 100% the same (hence my 'pretty much the same' comment), but it's about as close as I could find 'in the wild' WITH a .ico file.

    If it were the apache settings, why would some favicon.ico's display while others do not?

    As far as I can tell, NO .ico files display in this format on your site:

    example.com/demo/SUBSITE/wp-content/themes/THEMENAME/images/favicon.ico

    Is that correct?

  24. Josh Stauffer
    Member
    Posted 2 years ago #

    After testing on localhost and looking at another press75 demo, I concede defeat. I apologize if I have wasted your time.

    Now, I need to figure out how to get this to work with HostGator.

  25. Nah, it's a cool ... uh mental exercise? :) I mean, that's a WILD error.

    Interestingly. If you go to http://www.themeweaver.net/demo/graceful/wp-content/themes/graceful/images it will REDIRECT YOU to http://www.themeweaver.net/demo/wp-content/themes/graceful/images

    That tidbit I posted before is the most telling of where the whacky is! Something is redirecting /images/ folders!

  26. yeah we know you're not being stubborn. ;) Pretty sure it's something picky on their servers as there's other threads here with some image hiccups on hostgator with multisite installed in a subfolder.

  27. Josh Stauffer
    Member
    Posted 2 years ago #

    @Ipstenu and @Andrea_r,

    Thanks for you patience!

    I will attempt to work with HostGator to see if I can get this resolved.

    If there is no simple solution to this, would you say that multisite installed as a subdomain is more "cross-host compatible" than a subfolder install? http://www.example.com/demo/ vs. http://demo.example.com/

  28. If there is no simple solution to this, would you say that multisite installed as a subdomain is more "cross-host compatible" than a subfolder install?

    No. :) I would still say "it depends".

    If my desktop hadn't died I'd be able to test this better, as I had multiple installs in subfolders.

  29. What she said :)

    (And my excuse is I too just got a new laptop and can't be bothered to reinstall MAMP)

  30. Josh Stauffer
    Member
    Posted 2 years ago #

    After going a few rounds with HostGator, here's what they have to say about this matter.

    Hello,

    We have looked over your configuration, our configuration, and our logs. As you noted, the issue only happens with the favicon.ico file, and works if you don't use the virtual multisite URL. After checking our Apache configuration, I found nothing specific to favicon.ico in any of our configuration files. I did find that this is a redirect problem, as shown with the following log entries:

    # tail -f /etc/httpd/logs/error_log | grep 74.202.255.243
    [Fri Jul 01 14:44:26 2011] [error] [client 74.202.255.243] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.
    [Fri Jul 01 14:44:26 2011] [error] [client 74.202.255.243] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

    As you know, WordPress handles nearly all of it's redirects internally, and WordPress does not appear to be functioning correctly when redirecting the favicon.ico and only favicon.ico. At this point, this is a WordPress issue that we are unable to assist. We recommend consulting a third-party developer through a site such as http://elance.com. Please note that if you would like to us to turn on LogLevel debug for Apache, as noted in the error, we will be unable to do that at this time, as this generates far too many log entries and can cause unnecessary load on our shared servers.

    You are also welcome to review our VPS and Dedicated servers, which do allow this level of debugging and customization to assist with problems relating to scripts. You can review our offerings at:

    http://hostgator.com

    If you have any issues or concerns that we may assist, please let us know, and we'll be happy to do so.
    Jason [last name removed]
    Linux Systems Administrator
    HostGator.com LLC

Topic Closed

This topic has been closed to new replies.

About this Topic