WordPress.org

Ready to get started?Download WordPress

Forums

Fatel error message (12 posts)

  1. jennifer55
    Member
    Posted 1 year ago #

    Hi

    I am getting:

    Fatal error: Allowed memory size of 100663296 bytes exhausted (tried to allocate 24 bytes) in /home/xxxxxx/public_html/mywebsite.co.uk/wp-includes/wp-db.php on line 1545

    I've taken a look, but the file is no different from another wp installation which is running sweetly.

    The hosting company I am with tells me I have to fix the problem. But how?

    The website has been running fine all week, and I've just discovered the problem today - although I haven't touched anything.

    I always keep everything up to date - though I don't think I have touched the site since it was running smoothly several days ago.

    The site has been taking a feed from amazon.co.uk through 'Feedword press plugin' through a cron job - I have now deleted the cron so no more feeds - but I can't get into wp-admin. The amazon feed is the only thing I can think has caused the problem.

    Would it be a good idea to start from scratch again with a new installation of WP, but linking with the original database?

    Your help would be much appreciated.

    Jennifer

  2. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    Please scan your site at Sucuri and report back...

    http://sitecheck.sucuri.net/scanner/

  3. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

  4. jennifer55
    Member
    Posted 1 year ago #

    Thanks for your help.

    To expand further. There are three websites that uses amazon feeds and the 'Feedword Press' plugin.

    (I'm a bit reluctant to mention the sites name in case there is a vulnerability issue?)

    One is a .com and it gets it's feed from amazon.com - there is no problem with this site! It appears to be running fine (although the feed has stopped as the cron job has been cancelled).

    There are problems with the two sites that get their feed from amazon.co.uk. Both of these I've ran through the sucuri scan.

    1. One I am getting:

    Fatal error: Allowed memory size of 100663296 bytes exhausted (tried to allocate 24 bytes) in /home/xxxxxx/public_html/xxxx.co.uk/wp-includes/wp-db.php on line 1545

    The scan shows clear, there are no issues. Though I can't get any further than the fatal error message. The first page does come up though I think this in the cache, as soon as I click to go to wp-admin the message appears.

    2. The other site shows:

    HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfil the request.

    This site has a normal html index page which opens fine, with a link clicks to a wordpress site.

    For this the scan has a warning:

    web site: grandparentslove.co.uk/ibooks/
    status: Site with warnings
    web trust: Not Blacklisted
    warn: Unable to properly scan your site. Site empty (no content).

    I am now going to check WPyogi's codex link.

    Again, I really appreciate any help.

  5. jennifer55
    Member
    Posted 1 year ago #

    I received this message from the technical dept of my hosting plan:

    We have copied the server-wide php.ini configuration file to your public_html/mywebsite.co.uk/ directory, and set the 'memory_limit' value from 96M to 128M. Now your website opens without any issues.

    The above worked for a short time (probably until the next feed was executed from amazon) then it stopped.

    So... if I add:

    define('WP_MEMORY_LIMIT', '96M');

    to the wp-config.php do you think this would help?

    Sorry, but I am trying to tread cautiously in case I make the situation worse.

  6. jennifer55
    Member
    Posted 1 year ago #

    OK stupid question, it looks like serverside they increased the memory limit without the wp-config.php being amended.

    So would it necessary to increase the memory through the wp-config.php?

  7. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    Sure, allow WP it's max allowed by host...

  8. jennifer55
    Member
    Posted 1 year ago #

    Thanks for your reply:

    Have added - define('WP_MEMORY_LIMIT', '128M');

    in the area below - do I need to change the WP-DEBUG to 'true'?

    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', false);
    define('WP_MEMORY_LIMIT', '128M');
    
    /* That's all, stop editing! Happy blogging. */

    Get the message when trying to access wp-admin:

    Fatal error: Allowed memory size of 100663296 bytes exhausted (tried to allocate 79 bytes) in /home/xxxxx/public_html/mysite.co.uk/wp-includes/wp-db.php on line 1545

    Sorry if my questions are obvious, I'm pretty basic!

  9. Fatal error: Allowed memory size of 100663296 bytes exhausted (tried to allocate 79 bytes) in /home/xxxxx/public_html/mysite.co.uk/wp-includes/wp-db.php on line 1545

    100663296 bytes == 96MB

    There are some optimizations that you can select from within the plugin. Go to
    mysite.co.uk/wp-admin/admin.php?page=feedwordpress/performance-page.php

    Click the add index on guid column in database and see if that solves your problem. If not then also try the optimize queries ( please do a database backup before enabling this ).

    If your site is using huge feeds and constantly hitting php memory limits then you should probably upgrade from shared hosting to a VPS with dedicated memory so you can set your php limits higher if needed.

  10. jennifer55
    Member
    Posted 1 year ago #

    Wont let me in at all. I can't access wp-admin.

    Going through the browser is the same. Feedwordpress does have a performance-page.php and a diagnostics-page.php - but nothing will open.

    To be honest, I've dabbled into the feed, which worked great for a week.

    I've already decided to forego the feed as economically it wouldn't be worth upgrading to VPS.

    The browser loads other files that are not in within wordpress, such as the readme.html page.

    Surely this is a datatbase problem right?

    So installing a fresh wordpress file and connecting to the database, wouldn't work?

    Thank you Chris for your taking time to reply.

  11. jennifer55
    Member
    Posted 1 year ago #

    Hi

    A message has come back from the technical dept at the host server:

    This issue is still related to the sql query, you need to optimize it.

    Sorry, to ask but here comes another question, which is the best way to do this?

    Has anyone else had this problem?

  12. jennifer55
    Member
    Posted 1 year ago #

    I guess this is resolved now, I have started from basic again, although I managed to save links, etc.....

    What I've learnt:

    - BACK UP! BACK UP! BACK UP! BACK UP!

    - Make sure the 'safe information' button is switched OFF on a feed!

    - How much data can be created without even realising it.

    Good lessons learnt!

Topic Closed

This topic has been closed to new replies.

About this Topic