WordPress.org

Ready to get started?Download WordPress

Forums

Link Library
Fatal thumbnail error? (3 posts)

  1. grugnir
    Member
    Posted 1 year ago #

    When trying to generate a thumbnail image using the "Generate Thumbnail and Store locally" button:
    <b>Fatal error</b>: Call to undefined method link_library_plugin::ll_get_link_image() in <b>[serverpathyaddayaddayadda...]/wp-content/plugins/link-library/link-library-image-generator.php</b> on line <b>19</b>
    is what appears in the "Image Address" box. Any ideas?

    WP 3.5.1
    LL 5.7.9.2 (but was happening before update)
    using valid Thumbshots API key

    http://wordpress.org/extend/plugins/link-library/

  2. grugnir
    Member
    Posted 1 year ago #

    FWIW:
    Been fiddling some more and found that if I go to >Link Library >Library Settings and hit the "Generate Thumbnails and Store locally" button there, it works...

    :-?

    EDIT: only change is update to LL 5.7.9.4

  3. yezzz
    Member
    Posted 11 months ago #

    I can confirm this bug and workaround.

    On the link page, after clicking the generate thumbnail button a popup shows up "thumbnail succesfully generated for ..." and the "no image assigned" text disappears (in IE changes to a red cross).
    Then the error message is displayed in the image address of the advanced box.

    Also, in the library, the generate favorite icon function generates bad images: 0kB.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic